Download it now!
Bug 75842 - Copy & Paste Cells to thunderbird Only Paste Text with tab delimited not as HTML Table
Summary: Copy & Paste Cells to thunderbird Only Paste Text with tab delimited not as H...
Status: RESOLVED DUPLICATE of bug 74584
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-03-06 13:44 UTC by walid
Modified: 2015-01-24 13:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Pasting Comparision between "4.2.2.1 rc" and 4.1 (8.35 KB, image/png)
2014-03-06 13:44 UTC, walid
Details
Copy Formated datas from Calc to Thunderbird (141.09 KB, image/png)
2014-03-06 17:24 UTC, Jacques Guilleron
Details
Copy formated datas from Calc to Thunderbird (90.67 KB, image/png)
2014-03-06 17:43 UTC, Jacques Guilleron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description walid 2014-03-06 13:44:38 UTC
Created attachment 95228 [details]
Pasting Comparision between "4.2.2.1 rc"  and 4.1

When Copying and pasting cells from Calc (4.2.2.1 rc) to Thunderbird , Only Text is Pasted as TAB delimited. from Calc 4.1 and eariler, the Text is Pasted with a Table 


- create spreadsheet in LibreOffice calc
- open thunderbird
- copy cell range
- paste into thunderbird message
- From Calc 4.2.2.1 rc, Text is pasted as TAB delimited 
- From Calc 4.1, Text is pasted in a Table
Comment 1 walid 2014-03-06 14:22:23 UTC
I think this issue happens only on windows 
I tested (4.2.1) on ubuntu, it pastes as expected
Comment 2 Jacques Guilleron 2014-03-06 17:24:30 UTC
Created attachment 95231 [details]
Copy Formated datas from Calc to Thunderbird
Comment 3 Jacques Guilleron 2014-03-06 17:43:17 UTC
Created attachment 95232 [details]
Copy formated datas from Calc to Thunderbird
Comment 4 Jacques Guilleron 2014-03-06 17:53:26 UTC
Hello walid,

I just downloaded LO 4.2.2.1 and copied formated datas from Calc to Thunderbird and got it as Table as it can be seen in attachment. 
This works too with LO 4.3.0.0.alpha0+
Build ID: 7122ef19847b26529ed1d5bad40df869e91a8495
TinderBox: Win-x86@39, Branch:master, Time: 2014-03-06_00:38:21
on Windows 7 Home Premium.
 
Kind regards,

Jacques
Comment 5 Joel Madero 2014-03-06 20:27:45 UTC
@Walid - does it happen with every spreadsheet?
Comment 6 Joel Madero 2014-03-06 23:55:42 UTC
Confirmed:
Windows 8
LibreOffice 4.2.1.1

Also confirmed:
Not an issue in Ubuntu 13.10 w/ same release of LibreOffice

Marking as:
New
Normal - I guess can prevent high quality work - I'm not positive on that though
High - as it's been said that this is a regression bumping it up to High

Regression - based on nice bug report from Walid I am marking as regression

@Walid - thanks for the detailed bug report. If you have the time and can test other versions of 4.2+ it'd be nice to figure out where the bug was introduced.

http://downloadarchive.documentfoundation.org/libreoffice/old/

I would suggest testing from the first 4.2.0 - and then update the version to reflect the oldest version you can confirm the bug on.


Thanks!
Comment 7 Kohei Yoshida 2014-03-07 19:32:33 UTC

*** This bug has been marked as a duplicate of bug 74584 ***