Download it now!
Bug 74537 - Can't paste formatted test to other word processors
Summary: Can't paste formatted test to other word processors
Status: RESOLVED DUPLICATE of bug 74584
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 74523 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-04 20:25 UTC by Todd
Modified: 2014-02-19 20:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Clip board from LO 4.2 (10.23 KB, application/octet-stream)
2014-02-05 02:06 UTC, Todd
Details
the odt that was used to copy into the clipboard (9.64 KB, application/vnd.oasis.opendocument.text)
2014-02-05 02:07 UTC, Todd
Details
Clip board of the word doc (83.68 KB, application/octet-stream)
2014-02-05 02:07 UTC, Todd
Details
docs that was used to copy into the clipboard (12.55 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-02-05 02:10 UTC, Todd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2014-02-04 20:25:57 UTC
Hi All,

XP sp3
LO 4.2


I have a customer that sent me this (after upgrading from 3.1 to 4.2):

"LO will not copy and paste into anything that is not LO. This won't work for us, at all.   For example, I can copy/paste from LO to LO....... but not LO to WORD or LO to emails.  Phooey!!"

Upon investigation, I found that she was unable to paste formatted text to Word or Thunderbird (HTML mode) from LO Writer. She can paste the formatted text as simple text (paste special), but she loses the formatting.  She can paste formatted text from Word and Thunderbird into LO, just not the other way around.

I posted this on the forum and got told to file a bug.
http://en.libreofficeforum.org/node/7491#comment-30281

I am not able to reproduce this in the Linux version of LO 4.2 (were the clipboard is working beautifully).

Many thanks,
-T
Comment 1 Jacques Guilleron 2014-02-04 22:29:23 UTC
Hello Todd,

Thanks for report this.
I confirm that formatted text cannot be pasted to Word or Thunderbird, without losing formating, with LO 4.2.0.4 & Windows 7 Home Premium.
I am able to do it with LO 3.6.6.2 portable.
I set Status to NEW.

Kind regards,

Jacques
Comment 2 Todd 2014-02-05 02:06:32 UTC
Created attachment 93424 [details]
Clip board from LO 4.2

This is the clip board of a "copy" from LO 4.2.  Goes with the attached document
Comment 3 Todd 2014-02-05 02:07:12 UTC
Created attachment 93425 [details]
the odt that was used to copy into the clipboard
Comment 4 Todd 2014-02-05 02:07:43 UTC
Created attachment 93426 [details]
Clip board of the word doc
Comment 5 Todd 2014-02-05 02:10:05 UTC
Created attachment 93427 [details]
docs that was used to copy into the clipboard

I have attached two raw "clipboard" files created by copying text from the attached documents into the clipboard.

A comparison of the two clipboard file should show why LO's clipboard won't copy formatted text.  (One would hope)
Comment 6 Jacques Guilleron 2014-02-05 17:37:11 UTC
*** Bug 74523 has been marked as a duplicate of this bug. ***
Comment 7 Regina Henschel 2014-02-06 00:59:09 UTC
This sounds like the same problem as bug 74537.
Comment 8 Regina Henschel 2014-02-06 00:59:36 UTC
-> bug 74584.
Comment 9 Kohei Yoshida 2014-02-15 13:49:30 UTC
Setting the correct version. Nobody has tested the version originally specified.
Comment 10 Kohei Yoshida 2014-02-19 20:23:39 UTC
I confirm that this one shares the same root cause with Bug 74584.

*** This bug has been marked as a duplicate of bug 74584 ***