Bug 75567 - Copying blocks from draw to writer put legend anchor in a wrong position.
Summary: Copying blocks from draw to writer put legend anchor in a wrong position.
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste Object
  Show dependency treegraph
 
Reported: 2014-02-27 09:52 UTC by Marco Ciampa
Modified: 2018-12-27 10:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example douments (11.02 KB, application/vnd.oasis.opendocument.graphics)
2014-02-28 15:09 UTC, Marco Ciampa
Details
Example douments (12.20 KB, application/vnd.oasis.opendocument.text)
2014-02-28 15:09 UTC, Marco Ciampa
Details
Problem with bullets and anchor (23.54 KB, application/vnd.oasis.opendocument.graphics)
2014-03-06 19:42 UTC, Michel Belanger
Details
picture example of copy from draw / paste into writer (90.80 KB, image/jpeg)
2018-12-27 10:47 UTC, roumanet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Ciampa 2014-02-27 09:52:46 UTC
Copying blocks from draw to writer put legend anchor in a wrong position.

How to reproduce the problem:

 - open draw
 - create a _multiple_ object (with just one legend the problem is
   not so terrible since anchoring is wrong but is still editable)
   for example a box plus a legend
 - select all the objects
 - copy
 - open writer
 - paste
 - the pasted block will have the legend anchor _outside_ the block,
   not editable and in a wrong position.

workaround: always paste legends as single objects and not in a compound block
and then fix the anchor position at will.

Verified on LibO 4.2.1.1 Linux and Windows XP it is just the same.
Comment 1 Marco Ciampa 2014-02-27 10:58:55 UTC
Please note that the problem is in the label anchor. You see it even pasting just one label.

Other (better) workaround:

 - in libo write...
 - select the block
 - mouse dx button and un-block the objects
 - select label
 - fix the label anchor position
 - select all the objects
 - group all the objects

done!
Comment 2 Jean-Baptiste Faure 2014-02-28 05:35:11 UTC
Please attach a test document.
Set component to Draw.

Best regards. JBF
Comment 3 Marco Ciampa 2014-02-28 15:09:13 UTC
Created attachment 94892 [details]
Example douments
Comment 4 Marco Ciampa 2014-02-28 15:09:35 UTC
Created attachment 94893 [details]
Example douments
Comment 5 Marco Ciampa 2014-02-28 15:13:18 UTC
There is no need of example documents, just try to do as I said. Nevermind. I have created a very simplicist draw example document (hello.odg). If you select the objects in draw and then past the block in writer you obtain the attached document (hello.odg).
Comment 6 Jean-Baptiste Faure 2014-03-01 15:23:04 UTC
(In reply to comment #5)
> There is no need of example documents, just try to do as I said. Nevermind.
> I have created a very simplicist draw example document (hello.odg). If you
> select the objects in draw and then past the block in writer you obtain the
> attached document (hello.odg).

It is less time consuming for the community if you do the job one time instead of if each QA volunteer does it for his onw tests. ;-)

That said, thank you very much for your test documents.

Reproducible with LO 4.2.3.0.0+ and 4.1.5 under Linux / Ubuntu 13.10 x86-64
For me the legend is editable in Writer.

Best regards. JBF
Comment 7 Michel Belanger 2014-03-06 19:42:28 UTC
Created attachment 95235 [details]
Problem with bullets and anchor

This file shows a problem with bullets showing outside legend once paste in Writer
Comment 8 Marco Ciampa 2014-03-07 08:46:55 UTC
I see, this _could_ be another kind of problem (bug). The only way to find out it is trying to fix it and then testing if it fixies the other label problem too.
Comment 9 Joel Madero 2015-05-02 15:41:12 UTC Comment hidden (obsolete)
Comment 10 Marco Ciampa 2015-05-05 00:03:01 UTC
I confirm that this bug is still present in LibreOffice 4.4.2.2 Linux (Ubuntu) 14.04 amd64.
Apparently there are no changes in the bug behaviour.
Comment 11 QA Administrators 2016-09-20 09:37:04 UTC Comment hidden (obsolete)
Comment 12 Marco Ciampa 2016-09-20 12:35:31 UTC
I confirm that this bug is still present in LibreOffice 5.2.1.2 Linux (Ubuntu) 16.04 amd64.
Apparently there are no changes in the bug behavior.
Comment 13 QA Administrators 2018-07-04 02:48:51 UTC Comment hidden (obsolete)
Comment 14 Marco Ciampa 2018-07-05 08:58:12 UTC
The bug is still there in LibreOffice 6.0.5.2 ...
Comment 15 Marco Ciampa 2018-07-06 07:03:59 UTC
Component changed to LibreOffice from Draw since the problem is not (only) relevant to the Draw component...
Comment 16 roumanet 2018-12-27 10:47:45 UTC
Created attachment 147856 [details]
picture example of copy from draw / paste into writer

The bug is there in 6.1.2.4.

When trying others options with CTRL+Shift+V, the MetaFile Graphics Device Interface (GDI) did a good job, as well bitmap picture (but this one is crapy).