Download it now!
Bug 75574 - PRINTING: EMF from a document not printed or exported to PDF correctly on Windows
Summary: PRINTING: EMF from a document not printed or exported to PDF correctly on Win...
Status: RESOLVED DUPLICATE of bug 104252
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta1
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2014-02-27 13:37 UTC by Timur
Modified: 2016-12-28 15:28 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots, PDFs and EMF (732.04 KB, application/zip)
2014-02-27 15:59 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2014-02-27 13:37:54 UTC
Text document with EMF picture from https://bugs.freedesktop.org/attachment.cgi?id=76865 cannot be printed on Windows.

Print preview icon in Print dialog is wrong. Prints only part of EMF picture.
Comment 1 Mike Kaganski 2014-02-27 15:08:58 UTC
Reproducible with LO 3.6.0.4 and later, including 4.2.1.1 under Win7x64.
NOT reproducible with 3.5.7.2 and earlier -> regression.

Timur, I noted that you have set the version to 3.5.0, but I cannot reproduce it there. Are you sure that you saw this problem with that version? If so, please set the version back.
Comment 2 Mike Kaganski 2014-02-27 15:59:02 UTC
Created attachment 94830 [details]
Screenshots, PDFs and EMF

Attached are screenshots, printed PDFs and exported PDFs of the bugdoc from attachment 76865 [details]. Also, the EMF was extracted from the bugdoc, and included in the attachment as well.

As may be seen, v.3.5.7.2 shows print preview, prints and exports the file OK. Worth noting is that both generated PDFs contain the EMF data as text.

Starting with 3.6.0.4, print preview shows incorrect picture. Both printed PDF and exported PDF are wrong, but differently. Printed PDF has proper page size, while exported has wrong page size and more closely match the pront preview image. Also note that both PDFs contain raster image for the EMF (exported version image is larger than the page size). Operating the file is very slow, be it printing, exporting or zooming. Also notable that zooming causes parts of the text to disappear, just as on the printout. To see this, you may zoom to ~800% centering to colored line close to right margin.

Starting with 4.0.0.1, distortion changes (more text disappears). Slow operation and disappearing text on zoom are present, too.

The attached EMF (that was extracted from the .doc) may be opened with Draw. Then it will show the same problems, i.e. slow operation, disappearing of text, and wrong printing/exporting, with the same versions.

Also I tested the .doc with 4.2.1.1 under Ubuntu. There I cannot reproduce distorted print/export, nor disappearing text on zoom, but operation is still very slow.
Comment 3 Timur 2014-02-27 16:31:43 UTC
(In reply to comment #1)
> Reproducible with LO 3.6.0.4 and later, including 4.2.1.1 under Win7x64.
> NOT reproducible with 3.5.7.2 and earlier -> regression.

You're are right. I just copied my old comment, but it was wrong. Version 3.6.0.4 is correct. Versions 3.6.0.x are not available for further testing.
Comment 4 Mike Kaganski 2014-02-28 00:27:33 UTC
Already reproducible with 3.6.0.0.beta1.

Radek, Luboš, please excuse me for adding you to CC here, if it's not your area. I noticed that you were involved into doing some stuff with WMF/EMF/EMF+ in 3.6.0 (https://wiki.documentfoundation.org/Releases/3.6.0/Beta1). Could you please check if this issue is a regression that arose from those patches?
Comment 5 Timur 2014-10-13 17:21:36 UTC
Still the same problem in LO 4.2.6 and 4.3.2.
Comment 6 Timur 2014-10-20 14:22:50 UTC
AFAIK, this cannot be bibisected? What are the options for a fix?
Comment 7 Timur 2015-05-07 10:47:54 UTC
Same problem in 5.0-alpha.
Comment 8 Timur 2015-09-29 15:42:04 UTC
Looks like a duplicate of Bug 77525, that one is newer but it has a temporary resolution.

*** This bug has been marked as a duplicate of bug 77525 ***
Comment 9 Robinson Tryon (qubit) 2015-12-17 10:55:32 UTC Comment hidden (obsolete)
Comment 10 V Stuart Foote 2016-12-28 15:28:41 UTC
Workaround 

disable Tools -> Options -> View: "Use hardware acceleration" (or enable "OpenGL rendering" if system supports).


=-=-=
QA clean up of 77525, splitting it to bug 104252 and bug 103833

*** This bug has been marked as a duplicate of bug 104252 ***