Bug 75614 - FILEOPEN: Opening RTF file corrupt; after footnote text are missing.
Summary: FILEOPEN: Opening RTF file corrupt; after footnote text are missing.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium major
Assignee: Miklos Vajna
QA Contact:
URL:
Whiteboard: target:5.0.0 target:4.4.3 target:4.3....
Keywords: bibisectRequest, filter:rtf, regression
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2014-02-28 17:20 UTC by greatbalder
Modified: 2015-12-17 05:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
non-standard RTF (1.61 KB, application/x-zip)
2014-02-28 17:20 UTC, greatbalder
Details
Screenshot in MS Word Viewer (42.79 KB, image/png)
2014-11-22 16:59 UTC, Alexandr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description greatbalder 2014-02-28 17:20:17 UTC
Created attachment 94902 [details]
non-standard RTF

Some non-standard RTF file are opening incomplete, some text missing.
MS Word 2003 & WordPad opened file correct.
Comment 1 Urmas 2014-02-28 22:54:17 UTC
Confirming.
Comment 2 Buovjaga 2014-10-07 09:38:37 UTC
Confirming that this still occurs. The text is cut off after the reference number after "no man’s land". The reference itself is spared.

Version: 4.4.0.0.alpha0+
Build ID: 9177329a425cf70b515d1f266132838894fe54c6
TinderBox: Win-x86@39, Branch:master, Time: 2014-10-06_01:02:02
Comment 3 Alexandr 2014-11-22 16:59:49 UTC
Created attachment 109856 [details]
Screenshot in MS Word Viewer
Comment 4 Alexandr 2014-11-22 17:02:44 UTC
Reproducible with LibreOffice 4.3.3 and 4.4.0.0-beta1 on Debian x86_64. LibreOffice 3.5.4 crashes when I try to open the file.
Comment 5 Buovjaga 2015-01-09 15:23:45 UTC
Yep, 3.5 crashes, when opening, but 3.3 doesn't have the problem.

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 6 Buovjaga 2015-01-09 15:30:45 UTC
Added regression keyword, even though bibisecting might not be possible.
Comment 7 Matthew Francis 2015-01-25 15:21:10 UTC
Adding Whiteboard:bibisectRequest

(If in doubt, tag it with a request - if it's preBibisect we'll find out quickly enough)
Comment 8 tmacalp 2015-02-01 20:00:13 UTC
Well, the good news is that this isn't exactly prebibisect.  The bad news is that it is very difficult to bibisect.  Occasionally, under some miracle conditions, this document will not crash and will successfully load the document.  Sometimes it can take me over 100 tries.  Other versions/attempts never seem to be able to load the file.

I have no idea what would be causing the file to load sometimes, but not others.  I've been making use of a while loop to run LO repeatedly until it actually loads.  I've tried adjusting for other factors by wiping my config directory, removing the document lock file, and cleaning the bibisect directory in between every launch, but nothing seems to help with the crashes.

I attempted to perform an actual bibisect, but I keep running into situations where I can never actually launch the document.  I can at least limit the problem commit to somewhere between "last40onmaster" and "last41onmaster," but that's still a range 108 revisions.  I was able to somehow launch both of those versions and the "last40onmaster" revision had the full text, while "last41onmaster" showed the current cut-off behavior.

All I know is that I've racked up 2606 segfaults in my syslog testing this one.  But I might be doing something stupid and someone else might have better luck bibisecting, so I'll leave the whiteboard status as bibisectRequest.
Comment 9 Miklos Vajna 2015-04-10 21:37:05 UTC
The problem is that we normally start buffering of the text after \super to catch custom footnote/endnote markers, but that should stop at \chftn -- and it does not in this case.
Comment 10 Commit Notification 2015-04-12 14:50:46 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cec5f2eab25578a9859134d697c200089c597faa

tdf#75614 RTF import: fix missing text after footnote

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Miklos Vajna 2015-04-12 15:22:49 UTC
libreoffice-4-4 review: https://gerrit.libreoffice.org/15270
Comment 12 Commit Notification 2015-04-13 06:39:08 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a32b8e78b2847c39c3d51aad7f4a76a79370119c&h=libreoffice-4-4

tdf#75614 RTF import: fix missing text after footnote

It will be available in 4.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2015-04-13 06:40:21 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dee3f93a9e82fe320ce2de7078a32ecaa25e9c1b&h=libreoffice-4-3

tdf#75614 RTF import: fix missing text after footnote

It will be available in 4.3.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2015-04-20 10:09:37 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-7":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b1c6700aed0f8562c317132f6473344f04b7fea3&h=libreoffice-4-3-7

tdf#75614 RTF import: fix missing text after footnote

It will be available in 4.3.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Robinson Tryon (qubit) 2015-12-17 05:52:24 UTC
Migrating Whiteboard tags to Keywords: (filter:rtf, bibisectRequest)
[NinjaEdit]