Download it now!
Bug 75648 - FILESAVE as xlsx: cached formula result is not saved for calculated IF statements
Summary: FILESAVE as xlsx: cached formula result is not saved for calculated IF statem...
Status: RESOLVED DUPLICATE of bug 74747
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2014-03-01 19:36 UTC by pavelz
Modified: 2014-03-10 21:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple IF statement, save as xlsx and open (17.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-03-01 19:36 UTC, pavelz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pavelz 2014-03-01 19:36:51 UTC
Created attachment 94937 [details]
Simple IF statement, save as xlsx and open

When saving a spread sheet as xslx containing formula cells calculating IF statement, the formula result is not saved, instead TRUE (1) or FALSE (0) is saved.

It is similar to bug 51438.
Comment 1 Joel Madero 2014-03-02 17:01:57 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.2.0.0.alpha0+Build ID: 09a4c4d176ff97ab8ff4027af83a549991667baf
 Date:   Tue Jul 30 19:05:34 2013 +0300 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal - can prevent high quality work if user isn't aware that the value can be acheived by clicking into the cell, removing a single character and then re-entering the character (for instance go to end of formula and remove the ')' and then retype it, things then work as expected.

Highest - going to toss this on MAB list - having formulas work fine with ODS and then break with xlsx and then get fixed by not actually changing any value is quite strange.

Keywords - 

Whiteboard Status -

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 m.a.riosv 2014-03-02 17:18:37 UTC
A hard recalc [Shif+Ctrl+F9] gives the result correctly.
Also putting the option in:
Menu/Tools/Option/LibreOffice calc/Formula/Recalculation on file load - Excel 2077 and newer --> Always recalculate
works fine at opening.
I think remember that Marcus knows about this option.
Comment 3 Kohei Yoshida 2014-03-10 21:36:22 UTC
A fix for Bug 74747 also fixes this.

*** This bug has been marked as a duplicate of bug 74747 ***