Bug 75658 - FILEOPEN: Imported .docx charts have 2nd empty series
Summary: FILEOPEN: Imported .docx charts have 2nd empty series
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2014-03-02 02:28 UTC by Joey Reid
Modified: 2015-04-26 11:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
ms .docx files with chart showing empty series (11.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-03-02 02:28 UTC, Joey Reid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joey Reid 2014-03-02 02:28:50 UTC
Created attachment 94951 [details]
ms .docx files with chart showing empty series

I'm excited to see that LibreOffice can now open documents containing ms charts. Sometimes during the import process, a second "ghost" or empty series is rendered. This can unusually be fixed by changing the chart type to a new type and then changing back.
Comment 1 Jorendc 2014-03-05 12:59:51 UTC
I can confirm this behavior.

@Joey: 
* you did create this document yourself? (in other words: this document is only created and saved once (not saved/resaved/roundtripped multiple times?)

* What version of MS Office and operation system do you use?

Kind regards,
Joren
Comment 2 Joey Reid 2014-03-10 12:47:44 UTC
* you did create this document yourself? (in other words: this document is only created and saved once (not saved/resaved/roundtripped multiple times?)

Yes I created it myself. It was only created and saved in MS Office. 


* What version of MS Office and operation system do you use?

This was created on a Win 7 64-bit PC with Office 2007. 

To reproduce:
1. List a few numbers in a column in Excel
2. Create the chart in Excel with the chart wizard by selecting the data then Insert -> Chart -> Column -> 2D Column (or vertical bar type) 
3. Copy and paste it into Word.
4. Save
5. Open .docx in LO 4.2 or 4.3

Thanks for looking into this.
Comment 3 Joey Reid 2015-02-20 07:54:52 UTC
One clue that may help the developers track this down, is that the "ghost" can be removed by double clicking on the chart, changing the chart type to a different type, then changing it back to it's original type. So the internal data is correct but some glitch is being introduce in the importer logic.
Comment 4 Luke 2015-04-26 09:51:09 UTC
Verified fixed in:

Version: 5.0.0.0.alpha1+
Build ID: 3a96d8ead86dc210085f09076fd270f247442f0a
Comment 5 steve -_- 2015-04-26 11:14:33 UTC
WFM since we don't have a commit fixing this.