Bug 75671 - FILESAVE After open a xls and save as xls the linked cells in formula get linked to wrong cells and so show wrong results
Summary: FILESAVE After open a xls and save as xls the linked cells in formula get lin...
Status: RESOLVED DUPLICATE of bug 74345
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: All Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-02 11:36 UTC by kivi
Modified: 2015-01-24 13:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
3 example files as described in the Description of the bug (5.74 KB, application/zip)
2014-03-02 11:36 UTC, kivi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kivi 2014-03-02 11:36:57 UTC
Created attachment 94961 [details]
3 example files as described in the Description of the bug

I have found this problem after destroying some calculations with many linked sheets using Libre Office 4.2.0.4.
After open the xls file I did some small change (wrote a comment in a cell) and save it again as xls. Next time I open the file I found all calculations get wrong. After it I found the formulas get wrong only just after saving the file again as XLS.

This problem was available also in Libre Office 4.2.0.4 but there after save the formula get broken when open it open again with Libre Office 4.1.5.3 and also with Libre Office 4.2.0.4.

Now with Libre Office 4.2.1.1 if same file get saved as XLS it got broken formulas if open again with Libre Office 4.2.1.1 but looks OK when open with Libre Office 4.1.5.3.

I believe the reason for the problems must be some cells manipulations done by Libre Office 4.2.x during the save process, resulting in broken formulas.

Please see the attached Zip file. 
There are available 3 files.
1. The original file -  Created_by_LibreOffice-4.5.1.xls
2. Result_after_save_by_LibreOffice-4.2.0.xls
3. Result_after_save_by_LibreOffice-4.2.1.1.xls

If you fry to open the file Result_after_save_by_LibreOffice-4.2.1.1.xls with Libre Office 4.5.1 calculations inside will look OK, but if open it with Libre Office 4.2.1.1 they will look wrong.
Comment 1 m.a.riosv 2014-03-02 16:28:00 UTC
Hi Krasimir, thanks for reporting.

Reproducible:
Win7x64Ultimate.
Version: 4.2.1.1 Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b

But not reproducible:
Version: 4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f
http://downloadarchive.documentfoundation.org/libreoffice/old/4.2.2.1/

I think this is a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=74345

Changed the status to resolved duplicate, please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 74345 ***
Comment 2 Joel Madero 2014-03-02 16:31:09 UTC
I agree - looking at this bug it looks like it is fixed in 4.2.1
Comment 3 kivi 2014-03-03 12:21:35 UTC
I am sorry for reporting already sorted of bug.
I tried to check all spreadsheet bugs available but missed some how the bug 74345. May be was marked as Fixed. This is the reason why I wrote duplicate bug report. 
Sorry.
I am waiting for the next release to see this bug fixed finally.
Comment 4 Joel Madero 2014-03-03 15:43:04 UTC
No need to apologize. 4.2.1 is already available if you want to head over to our download page to test it out :)