Bug 75698 - UI: the "hide table boundaries" in Writer command does not work anymore
Summary: UI: the "hide table boundaries" in Writer command does not work anymore
Status: RESOLVED DUPLICATE of bug 75118
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-03-03 09:32 UTC by Andy
Modified: 2015-12-15 10:55 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2014-03-03 09:32:01 UTC
Problem description: when you create a table without borders, the command "hide/show table boundaries" of the "table" menu does not hide the gray lines showing them by default anymore; on the contrary, it adds to the table non existent black borders when switched to "hide". This is annoying, since the ability to visualize the page as it will be printed when using tables without borders (for example when using a table to arrange contents position) is a really useful option. Even worse, if you switch to print preview, where the appearance should strictly be as on paper (regardless of the setting of the above switch), the non existent black borders always appear.

Steps to reproduce:
1. open a new writer doc
2. create a table of any size, by default it will be without borders and with boundaries shown in light gray color
3. place the cursor anywhere in the table, and choose the command "table boundaries" in the "table" menu
4. Until 4.1 the table , as expected would become invisible; in 4.2.1 it shows non existent black borders
5. any further click on the "table boundaries" command switches from light gray to black boundaries, so that is it apparently impossible to see the page as it will be printed
6. now switch to "print preview"; the table will always have black borders while it should be invisible

Expected behavior: when clicking on the "table boundaries" command of a table without borders, its boundaries should be invisible.

              
Operating System: Windows 7
Version: 4.2.1.1 release
Last worked in: 4.1.4.2 release
Comment 1 A (Andy) 2014-03-08 10:04:53 UTC
reproducible with LO 4.2.1.1 (Win 8.1)

Note: To reproduce this bug you have to assure that BORDER in the OPTION section in the INSERT TABLE dialog box is unchecked.
Comment 2 Andy 2014-03-08 11:54:20 UTC
Yes, of course this is not a problem if you want to have table fully with borders; 
however, tables without borders are often used as a tool to organize the placement of some data on the page but without an explicit table with cells to be shown; 
even more common is the case when you create a table that should have SOME, but not all, borders visible (e.g. a table outlined only through vertical borders). In this latter case you may prefer to see all boundaries while editing the table, but then you want to hide boundaries to check the final look of the table with borders only where you need them.
Finally, if you want the table to have thin grey borders for some cells, it impossible to distinguish them from the boundaries, thus the correct working of "hide boundaries" function is then essential.
Comment 3 dany franck 2014-03-15 09:48:53 UTC

*** This bug has been marked as a duplicate of bug 75118 ***
Comment 4 Robinson Tryon (qubit) 2015-12-15 10:55:18 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]