Download it now!
Bug 75838 - FORMATTING: Red underline by spell checker is broken if you change the (cell) language
Summary: FORMATTING: Red underline by spell checker is broken if you change the (cell)...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 75839 76714 99409 (view as bug list)
Depends on:
Blocks: Spell-Checking Calc-Cells
  Show dependency treegraph
 
Reported: 2014-03-06 12:54 UTC by Jonas Müller
Modified: 2020-06-19 17:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
ODS file (14.88 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-03-06 12:54 UTC, Jonas Müller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Müller 2014-03-06 12:54:06 UTC
Created attachment 95226 [details]
ODS file

This is using german spell check by default, I don't know if this is different with another default language:

1. Open Example2.ods
2. As you can see a lot of the English text in Cell A1 is marked with a red underline. That is because the language of this Cell is German.
3. Highlight A1 and press Strg + 1 to go into the „format cell“ menu.
4. Go to „font“ and change the language to „English (UK)“
5. As you can see the English text still has a red underline despite having the correct language now. This is incorrect.
6. Now Highlight A1 and press F2 to edit the Cell.
7. As you can see now the German text get's a red underline. This is correct.
8. Press Esc to leave edit mode. Now the English text has a red underline again. This is incorrect.
9. This bug persists even if you Save & Close the file.
10. Now make a right click on A1 to enter edit mode.
11. As you can see now the red underline is & stays correct.

In short:

If you change a cell's language it doesn't show.
Comment 1 Joel Madero 2014-03-06 23:59:32 UTC
*** Bug 75839 has been marked as a duplicate of this bug. ***
Comment 2 A (Andy) 2014-03-08 09:48:27 UTC
reproducible with LO 4.2.1.1 (Win 8.1)
Comment 3 Jonas Müller 2014-05-13 08:13:34 UTC
The bug is still in LibreOffice  4.2.4.

In my opinion this is a really serious bug as it makes it really difficult to work with text of a different language in a spreadsheet. It looks really ugly when you have a whole spreadsheet full with red underlines despite making no mistakes.

The spell check features was always the one feature where LibreOffice Calc is so much better than MS Excel and I've always recommended it to colleagues if only for this feature...
Comment 4 QA Administrators 2015-06-08 14:43:19 UTC Comment hidden (obsolete)
Comment 5 Jonas Müller 2015-06-09 17:42:06 UTC
LibreOffice 4.4.3.2 is behaving a bit differently but this bug is essentially still there if you follow the steps mentioned.

It seems like the spell check doesn't work correctly after switching a cell's language.
Comment 6 Buovjaga 2016-05-03 13:28:30 UTC
*** Bug 99409 has been marked as a duplicate of this bug. ***
Comment 7 Tristan Miller 2017-01-22 13:41:01 UTC
Still reproducible in LibreOffice Calc 5.2.3.3.
Comment 8 Tristan Miller 2017-01-22 13:41:44 UTC
*** Bug 76714 has been marked as a duplicate of this bug. ***
Comment 9 QA Administrators 2018-05-01 02:32:07 UTC Comment hidden (obsolete)
Comment 10 Tristan Miller 2018-05-01 09:38:18 UTC
Still reproducible in LibreOffice 6.0.3.2.
Comment 11 QA Administrators 2019-05-02 02:47:59 UTC Comment hidden (obsolete)
Comment 12 Tristan Miller 2019-05-02 13:10:28 UTC
The problem still exists in LibreOffice 6.2.3.2.  I'm not seeing all the nuances described in the original report, but the basic problem remains that changing a cell's language does not cause the automatic spelling correction underlines to change.
Comment 13 christos 2020-06-19 17:30:49 UTC
It works for me.

Version: 6.3.6.2 (x64)
Build ID: 2196df99b074d8a661f4036fca8fa0cbfa33a497
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: fr-FR (en_US); UI-Language: en-US
Calc: threaded