Bug Hunting Session
Bug 75893 - FILESAVE: FORMCONTROLS: Form controls cannot be exported to docx format
Summary: FILESAVE: FORMCONTROLS: Form controls cannot be exported to docx format
Status: RESOLVED DUPLICATE of bug 50097
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-07 15:39 UTC by Zeki Bildirici
Modified: 2014-10-15 17:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file including some of the form controls. (12.91 KB, application/vnd.oasis.opendocument.text)
2014-03-07 15:39 UTC, Zeki Bildirici
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zeki Bildirici 2014-03-07 15:39:02 UTC
Created attachment 95305 [details]
Sample file including some of the form controls.

Hi,

Currently LibreOffice Writer cannot export any form controls to docx. format while it can export to doc and odt.

I've created a sample document and attached. Saving as docx then opening it either with LibreOffice Writer or Microsoft word will result an empty doc.

There are some bug reports already reported but for specific form controls like text box, radio button etc, but i can say that none of these form controls can be exported.

Form controls are very important in corporate usage, and such problem has a high priority for such users. 

Some of the related bug reports:
- https://bugs.freedesktop.org/show_bug.cgi?id=52191
- https://bugs.freedesktop.org/show_bug.cgi?id=54235
- https://bugs.freedesktop.org/show_bug.cgi?id=50097
- https://bugs.freedesktop.org/show_bug.cgi?id=70302

Best regards,
Zeki
Comment 1 Thomas van der Meulen 2014-03-22 09:59:07 UTC
Thank you for your bug report, I can reproduce this bug running 
Version: 4.2.3.1
Build ID: 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13
OS: Mac osx 10.9.2

I have changed the titles in the other bugs to let know that they are from the same function.
Comment 2 Matthew Francis 2014-10-15 17:33:41 UTC

*** This bug has been marked as a duplicate of bug 50097 ***