Download it now!
Bug 75936 - Moving Bullets to left
Summary: Moving Bullets to left
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-09 02:20 UTC by Stan Palmer
Modified: 2015-05-06 17:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
attachment-8964-0.html (6.16 KB, text/html)
2014-03-12 02:19 UTC, Stan Palmer
Details
attachment-8964-1.dat (1 bytes, multipart/alternative)
2014-03-12 02:19 UTC, Stan Palmer
Details
Requested Test File_Bug 75936.odt (18.47 KB, application/vnd.oasis.opendocument.text)
2014-03-12 02:19 UTC, Stan Palmer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stan Palmer 2014-03-09 02:20:32 UTC
Increasing an indent (moving to the right) of a bulleted statement works as expected.  However, decreasing the indent (move to the left) the bullet jumps to the far left of the page rather than moving back a single level.
Comment 1 tommy27 2014-03-09 09:37:21 UTC
please upload test file

do you increase/decrease indent with the proper GUI buttons or using the tab key?

moreover do you select the whole bulleted list or just some of it's items?
Comment 2 Stan Palmer 2014-03-12 02:09:27 UTC
The Tab button works to increase the indent.  However, when using the GUI buttons to decrease the indent, that is when the symbol jumps to the far left but the line item does not move.  Continuous clicking on the decrease indent button results in the symbol jumping farther to the left until if finally disappears from the page. 

Seems to be the case whether I select one or more bulleted items.

When increasing the indent via the GUI button, the item moves appropriately, but the symbol does not change (like it does using the Tab key).  Moving multiple items via the Tab key results in the items being deleted from the page/screen.

Hope that helps.



On Sunday, March 9, 2014 5:37 AM, "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> wrote:
 
 
tommy27  changed bug 75936 

What
Removed
Added
CC    barta@quipo.it  
Comment # 1 on bug 75936 from tommy27  
please upload test file do you increase/decrease indent with the proper GUI buttons or using the tab
key? moreover do you select the whole bulleted list or just some of it's items?
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 3 Stan Palmer 2014-03-12 02:19:34 UTC
Created attachment 95631 [details]
attachment-8964-0.html

My apologies, I hit send before uploading the test file.  I have uploaded the file in this send. 





On , Stan Palmer <palmerstan60@yahoo.com> wrote:
 
The Tab button works to increase the indent.  However, when using the GUI buttons to decrease the indent, that is when the symbol jumps to the far left but the line item does not move.  Continuous clicking on the decrease indent button results in the symbol jumping farther to the left until if finally disappears from the page. 

Seems to be the case whether I select one or more bulleted items.

When increasing the indent via the GUI button, the item moves appropriately, but the symbol does not change (like it does using the Tab key).  Moving multiple items via the Tab key results in the items being deleted from the page/screen.

Hope that helps.



On Sunday, March 9, 2014 5:37 AM, "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> wrote:
 
tommy27  changed bug 75936 

What
Removed
Added
CC    barta@quipo.it  
Comment # 1 on bug 75936 from tommy27  
please upload test file do you increase/decrease indent with the proper GUI buttons or using the tab
key? moreover do you select the whole bulleted list or just some of it's items?
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 4 Stan Palmer 2014-03-12 02:19:35 UTC
Created attachment 95632 [details]
attachment-8964-1.dat
Comment 5 Stan Palmer 2014-03-12 02:19:35 UTC
Created attachment 95633 [details]
Requested Test File_Bug 75936.odt
Comment 6 Björn Michaelsen 2014-03-12 11:51:58 UTC
Did this never work in previous releases or is this a regression?
(Also: Possibly related to fdo#42708).
Comment 7 sophie 2014-03-12 14:39:59 UTC
I can reproduce with a new document using version 4.1.5.3 under Debian and 4.2.2.1 under Ubuntu. If you have a long text append to a bullet, even the text disappears with the bullet out of the page.
Change plateform to all, set as New - Sophie
Comment 8 tommy27 2014-03-12 18:22:46 UTC
(In reply to comment #6)
> Did this never work in previous releases or is this a regression?
> (Also: Possibly related to fdo#42708).

It seems it has always been like that.
I can reproduce it in LibO 3.3.3 and AOO 4.0.0
hence issue is inherited from OOo
Comment 9 Commit Notification 2014-03-17 11:02:19 UTC
abdulmajeed ahmed committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f0dc2d755932b00b83db884334bcd0741056c884

Fix fdo#75936 set limit for decreasing indent



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 abdulmajeed 2014-03-20 08:19:28 UTC
Hi,
is it a good idea to disable the decrease indent button when the limit reached?

That mean the button is disabled from the start and it will be enabled if you increased the indent.
Comment 11 Gordo 2015-05-06 17:18:17 UTC
Could not reproduce.

Windows Vista 64
Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16

and

4.3.6.2

4.2.8.2 Decrease indent is an option.

Changed to RESOLVED FIXED because of commit.