Bug 75958 - FILEOPEN: Badly misplaced graphics in MS Word .doc files when imported into LibreOffice Writer
Summary: FILEOPEN: Badly misplaced graphics in MS Word .doc files when imported into L...
Status: RESOLVED DUPLICATE of bug 78756
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA interoperabillity
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks:
 
Reported: 2014-03-09 20:45 UTC by declan_moriarty
Modified: 2016-10-05 16:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
MS Word 2002/XP .doc file with image obliterating text in table. (48.50 KB, application/msword)
2014-03-09 20:45 UTC, declan_moriarty
Details
MS Word 2002/XP .doc file with image going over top line of caption. (72.50 KB, application/msword)
2014-03-09 20:53 UTC, declan_moriarty
Details
MS Word rendering of Sea Launch plus image JPEG file. (144.01 KB, image/jpeg)
2014-03-09 21:13 UTC, declan_moriarty
Details
MS Word rendering of Right ramp deployment plus image JPEG file. (126.19 KB, image/jpeg)
2014-03-09 21:16 UTC, declan_moriarty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description declan_moriarty 2014-03-09 20:45:02 UTC
Created attachment 95428 [details]
MS Word 2002/XP .doc file with image obliterating text in table.

Problem description: 
These 2 files have misplaced graphics when imported into LibreOffice Writer.  Sea Launch plus image.doc is the worst.  The picture completely covers the text in the table, and the picture should appear in the next cell on the right of the text.  The other file has the picture going over the first line of the text caption, but the text is flowed around it.  
Steps to reproduce:
1. Open files in LibreOffice Writer.

Current behavior:
Sea Launch plus image.doc - image completely obliterates text in table.
Right Ramp deployment plus image.doc - The picture goes over the top line of the caption and the first letter of the first word is put on the top line with the rest of the word on the 2nd line.

Expected behavior:
Sea Launch plus image.doc - The picture should be in the next cell to the right as in the MS Word screen dump.
Right Ramp deployment plus image.doc - The caption should be placed below the picture without any words to the right of the picture at all, all text should be below the picture.

Note that this worked in 4.0.6.2.  The problem with Sea Launch plus image.doc happens in Windows XP with 4.2.1.2 as well as Mac OS X.
              
Operating System: Mac OS X
Version: 4.1.3.2 release
Comment 1 declan_moriarty 2014-03-09 20:53:25 UTC
Created attachment 95434 [details]
MS Word 2002/XP .doc file with image going over top line of caption.
Comment 2 declan_moriarty 2014-03-09 21:13:29 UTC
Created attachment 95446 [details]
MS Word rendering of Sea Launch plus image JPEG file.
Comment 3 declan_moriarty 2014-03-09 21:16:40 UTC
Created attachment 95449 [details]
MS Word rendering of Right ramp deployment plus image JPEG file.
Comment 4 declan_moriarty 2014-03-09 21:20:29 UTC
Note that these word files are new MS Word 2002/XP .doc files.
Comment 5 declan_moriarty 2014-03-09 21:22:01 UTC
Note that this is a regression.
Comment 6 Thomas van der Meulen 2014-03-22 09:51:26 UTC
Thank you for your bug report, I can reproduce this bug running 
Version: 4.2.3.1
Build ID: 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13
OS: Mac osx 10.9.2

I have compared it with microsoft word and there is formats fine.
Comment 7 Robinson Tryon (qubit) 2014-09-05 07:52:09 UTC Comment hidden (obsolete)
Comment 8 Robinson Tryon (qubit) 2015-12-10 07:29:17 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2016-09-12 12:22:52 UTC
Adding keyword 'bibisectRequest'.
Comment 10 Xisco Faulí 2016-10-05 16:51:50 UTC
Regression introduced by 4e07258cbd1f4fb16d6ce2174fb5c74c3b36da33, which is the same commit as in bug 78756, thus closing this one as duplicated

*** This bug has been marked as a duplicate of bug 78756 ***