Bug Hunting Session
Bug 75973 - password protected library does not honnor end user type definition
Summary: password protected library does not honnor end user type definition
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.2
Keywords:
Depends on:
Blocks: Macro
  Show dependency treegraph
 
Reported: 2014-03-10 10:17 UTC by Laurent Godard
Modified: 2019-09-22 14:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
password protected library containing a macro with end user type definition (40.67 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-03-10 10:17 UTC, Laurent Godard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Godard 2014-03-10 10:17:10 UTC
Created attachment 95494 [details]
password protected library containing a macro with end user type definition

occurs since at least LO 3.5.4

open the attached sample file, accept macro, click the Test me button
--> an error occurs

goto manage libraries, remove the password of MyLibrary of the sample file (the password is 'password')
click the testMe button
--> no more error, the print statement is ok
Comment 1 sophie 2014-03-10 13:00:29 UTC
Confirmed with 4.2.2.1 set as New - Sophie
Comment 2 Noel Power 2014-03-16 02:30:45 UTC
Is it a bug or enhancement ? no idea but for sure this doesn't work, first I thought this was actually a code bug with the buffer transformation work that was done for increasing module code size capacity ( see PCodeBuffConvertor etc. )
So.. the bad news is that either by oversight or design actually the case here is actually as the bug title suggests e.g. that user types are not supported for password protected Libraries. The missing part is that the user types (actually the names) need to be somehow stored to the binary image format ( and of course reconstructed etc. on load )

On a more positive note it shouldn't really be too hard to add support for this. On thing that is needed is a new version for the binary format of basic image so that this new feature can be cleanly supported. Luckily we already have a new version ( that was created for natively saving the new image binary format (for supporting bigger modules) and we currently don't write the new image version anywhere ( although all the code to support it is in place ) Why don't we ? the  reason is simple oversight, the new binary image format needed to be introduced on a office version bump ( which at the the work was done for that feature was in the future ) probably the whole openoffice/libreoffice split had something to do with this ( or perhaps it was forgotten about independantly ) but... in anycase we do have support for a new image version already in place in the current libreoffice ( and older libreoffice ) versions. It should be easy to introduce the new image version (with additional support for user defined types) at the same time. I will look into it and at the very least try and put some code pointers here (and/or maybe even a patch)
Comment 3 Noel Power 2014-03-16 03:38:23 UTC
(In reply to comment #2)
It should be easy to introduce the new image version
> (with additional support for user defined types) at the same time. I will
> look into it and at the very least try and put some code pointers here
> (and/or maybe even a patch)
easy :-)) well that of course assumes that one can find a way to easily persist the user types (or the information to rebuild the usertypes)
Comment 4 Commit Notification 2015-08-18 09:51:34 UTC
Laurent Godard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0405975042e91e5cca56068ad0d16ad8ab910737

tdf#75973 : User Defined Types in password encrypted macros

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-08-31 10:22:23 UTC
Laurent Godard committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cd91509191bee9faaabdae185fef58b811f3a5a4&h=libreoffice-5-0

tdf#75973 : User Defined Types in password encrypted macros

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2016-09-15 22:13:02 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 7 Xisco Faulí 2017-09-29 08:49:39 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.4.1 or 5.3.6  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20170929