Download it now!
Bug 75978 - Writer: complex OOXML .docx table is causing LibreOffice to hang during import filtering
Summary: Writer: complex OOXML .docx table is causing LibreOffice to hang during impor...
Status: RESOLVED DUPLICATE of bug 51785
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Tushar Bende
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-10 13:10 UTC by Priyanka Gaikwad
Modified: 2015-01-23 15:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LO hanged while opening this attached .Docx (28.17 KB, application/msword)
2014-03-10 13:10 UTC, Priyanka Gaikwad
Details
clip of test docx first page from Word 2007 (66.01 KB, image/png)
2014-03-10 14:57 UTC, V Stuart Foote
Details
clip of test docx second page from Word 2007 (49.08 KB, image/png)
2014-03-10 14:58 UTC, V Stuart Foote
Details
clip of test docx in web view from Word 2007 (91.87 KB, image/png)
2014-03-10 14:59 UTC, V Stuart Foote
Details
backtrace with symbols from SIGABRT (15.52 KB, text/plain)
2014-03-10 17:16 UTC, Terrence Enger
Details
typescript with backtrace from failed OSL_ENSURE (590.71 KB, text/plain)
2014-03-10 18:44 UTC, Terrence Enger
Details
zip of 7 stack trace slices for hung LODev 430 TB39 opening of this document containing complex table (5.88 KB, application/zip)
2014-03-10 19:00 UTC, V Stuart Foote
Details
Rendering of ODF .odt table in Word 2013 (267.34 KB, image/jpeg)
2014-03-10 20:58 UTC, V Stuart Foote
Details
Rendering of the same ODF .odt table in LibreOffice Dev 4.3.0alpha+ (208.44 KB, image/jpeg)
2014-03-10 20:59 UTC, V Stuart Foote
Details
document exported to ODF .odt from Word 2013 (36.58 KB, application/vnd.oasis.opendocument.text)
2014-03-10 21:04 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Priyanka Gaikwad 2014-03-10 13:10:32 UTC
Created attachment 95504 [details]
LO hanged while opening this attached .Docx

Libreoffice is getting hanged while opening document containing tables.Specifically issue is with row spanning.
Comment 1 V Stuart Foote 2014-03-10 14:57:19 UTC
Created attachment 95507 [details]
clip of test docx first page from Word 2007

Confirming writer hang when opening this document with 4.2.2.1 final and a recent 4.3.0alpha+ of master on Windows 7 sp1, 64-bit us-EN

However, document does not behave especially well in Office 2007 Word either.

Attaching clips of page 1 and 2, and also as web view.
Comment 2 V Stuart Foote 2014-03-10 14:58:05 UTC
Created attachment 95508 [details]
clip of test docx second page from Word 2007
Comment 3 V Stuart Foote 2014-03-10 14:59:30 UTC
Created attachment 95509 [details]
clip of test docx in web view from Word 2007

note in this web view considerable shift in column alignment and extensive vertical text.
Comment 4 V Stuart Foote 2014-03-10 15:11:17 UTC
On Windows 7 sp1, 64-bit.

The example .docx does not open and causes hang in earlier releases I have available...

Version: 4.1.5.3
Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24

and the earlier

Version 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)

Setting version accordingly.

@Priyanka, to your knowledge has this document or similar from template EVER opened in LibreOffice or earlier OpenOffice releases?
Comment 5 V Stuart Foote 2014-03-10 15:13:06 UTC
QA administrative -- setting component to writer, and removing assignee
Comment 6 V Stuart Foote 2014-03-10 15:25:06 UTC
confirmed the .docx also hangs on Linux (Fedora 20) with
Version: 4.2.1.1
Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b

setting to needinfo regards origin of template and the example document having ever opened correctly on LibreOffice or earleir OpenOffice releases.
Comment 7 Terrence Enger 2014-03-10 17:16:49 UTC
Created attachment 95519 [details]
backtrace with symbols from SIGABRT

With master commit 806f4d8, fetched 2014-03-04, configured as:
    --enable-option-checking=fatal
    --enable-dbgutil
    --enable-crashdump
    --without-system-postgresql
    --without-myspell-dicts
    --with-extra-buildid
    --without-doxygen
    --with-external-tar=/home/terry/lo_hacking/git/src
built and running on debian-wheezy 64-bit, I have managed to provoke a
SIGABRT.  The interesting part of the terminal output is:
    /usr/include/c++/4.7/debug/vector:366:error: attempt to access an element 
        in an empty container.

    Objects involved in the operation:
    sequence "this" @ 0x0x39300c8 {
      type = NSt7__debug6vectorIN5boost10shared_ptrINS0_IiSaIiEEEEESaIS5_EEE;
    }
    Application Error


    Fatal exception: Signal 6

This is another case of an assertion raised by a STL debug container.
It may not be exactly the crash originally reported, but hopefully it
happens earlier and more informatively.
Comment 8 Terrence Enger 2014-03-10 17:20:16 UTC
Whoops, wrong bug report.  Please ignore comment7 and the attachment.

Sorry for the noise.
Comment 9 Terrence Enger 2014-03-10 18:44:18 UTC
Created attachment 95526 [details]
typescript with backtrace from failed OSL_ENSURE

With my debug build of master, LibreOffice pegged the CPU and filled
up the terminal output buffer with:
    warn:legacy.osl:5582:1:sw/source/core/table/swnewtable.cxx:203: Wrong box found

Attachment has a backtrace from the first occurrence.
Comment 10 V Stuart Foote 2014-03-10 19:00:30 UTC
Created attachment 95529 [details]
zip of 7 stack trace slices for hung LODev 430 TB39 opening of this document containing complex table

I unwound this a bit further.  The word .docx document shows an AppVersion value of 14.0000 (from docProps\app.xml) so that makes it Office 2010.

It opens in Office 2013 Word in compatibility mode. It is a very complex styled table with mixed text and row column spans.

I saved from Word 2013 as 2013 OOXML, and also as 97-2003 .DOC

But all versions (.DOCX-- 2010, 2013-- or .DOC) hang when attempting to open with LibreOffice
 
Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

Version: 4.2.2.1
Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f

and today's
Version: 4.3.0.0.alpha0+
Build ID: 0919979bd1da3379e030b353a097d8fe1fd8341a
TinderBox: Win-x86@39, Branch:master, Time: 2014-03-10_01:36:32

When trying to open CPU races to 50%, but no crash.

Attaching several stack traces of soffice.bin from throughout an attempt at opening the original OOXML (Word 2010) version.

Setting NEW
Comment 11 V Stuart Foote 2014-03-10 20:58:17 UTC
Created attachment 95553 [details]
Rendering of ODF .odt table in Word 2013

Working with original OOXML in MS Word 2013, export to ODF and save as .odt format.

LibreOffice 4.2.0.4 Writer opens this ODF rendering mostly intact, as does current TB39 build of master. However, considerable difference in rendering of text and table cells between LibreOffice and MS Word 2013. Much of it apparently caused by mishandling of vertical oriented text in table cells.
Comment 12 V Stuart Foote 2014-03-10 20:59:59 UTC
Created attachment 95554 [details]
Rendering of the same ODF .odt table in LibreOffice Dev 4.3.0alpha+

attached JPEG of table header as rendered by LibreOffice Dev 4.3.0alpha+
Comment 13 V Stuart Foote 2014-03-10 21:04:02 UTC
Created attachment 95555 [details]
document exported to ODF .odt from Word 2013

exported ODF version of problem document that does open in LibreOffice
Comment 14 Tushar Bende 2014-04-04 10:46:30 UTC

*** This bug has been marked as a duplicate of bug 51785 ***