Download it now!
Bug 76016 - FILESAVE [DOCX] Empty Geometry Guide Name
Summary: FILESAVE [DOCX] Empty Geometry Guide Name
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-11 08:56 UTC by Vinaya Mandke
Modified: 2014-03-18 17:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Issue File (598.93 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-03-11 08:58 UTC, Vinaya Mandke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vinaya Mandke 2014-03-11 08:56:48 UTC
Steps to reproduce:-
1. Open the attached File in LO
2. Save in DOCX format
3. Open in MS Word 2010
4. Shows corrupt dialog
(the exported DOCX opens correctly in MS Word 2007)


XML in exported DOCX which causes corruption dialog to show:-

<a:prstGeom prst="upArrow">
    <a:avLst>
        <a:gd name="" fmla="val 5400" />
        <a:gd name="" fmla="val 5400" />
    </a:avLst>
</a:prstGeom>
Comment 1 Vinaya Mandke 2014-03-11 08:58:03 UTC
Created attachment 95582 [details]
Issue File
Comment 2 Jorendc 2014-03-11 17:54:34 UTC
I can confirm this corruption, tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: f32df2d590d0ee14f09664934457ba9e8de8cbe6
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-03-01_02:31:14

Roundtripped document opened with Word for Mac 2011.

Kind regards,
Joren
Comment 3 Commit Notification 2014-03-15 10:02:13 UTC
Vinaya Mandke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cdceca118b65f69d8c16bf3f8465f940aed73c10

fdo#76016 Changed oox/CustomTarget_generated.mk



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Jorendc 2014-03-18 17:08:26 UTC
I can not reproduce document corruption anymore. I assume this one is fixed? Marking as RESOLVED FIXED.

It looks like the text animation of the first page isn't preserved (other bug).

Thanks for fixing!

Tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 87efec9cc27b18aa09e50c289b503ba1127eb0b8
TinderBox: Win-x86@39, Branch:master, Time: 2014-03-18_02:50:50

Kind regards,
Joren