Bug 76081 - Dataloss: Calc breaks internal references when saved as *.xls
Summary: Dataloss: Calc breaks internal references when saved as *.xls
Status: RESOLVED DUPLICATE of bug 74345
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-12 15:44 UTC by a07cd040897db54e103c
Modified: 2014-03-12 23:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The original file created with calc 4.2.1.1 (18.06 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-03-12 15:44 UTC, a07cd040897db54e103c
Details
The file saved as *.xls with Calc 4.2.1.1 (6.50 KB, application/vnd.ms-excel)
2014-03-12 15:44 UTC, a07cd040897db54e103c
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a07cd040897db54e103c 2014-03-12 15:44:08 UTC
Created attachment 95670 [details]
The original file created with calc 4.2.1.1

When a document is created in calc where one sheet references various cells from another sheet the data seems fine as long as it is saved as *.ods (see attachment "lo_test_original.ods"). When such a document is saved as *.xls and opened in calc, the data still seems to be OK (but i doubt it is).

But when such a xls-document is opened in MS Office 2003, ALL referencing cells suddenly point to ONE special cell of the source sheet. (see attachment "lo_test_saved_as_xls.xls")

I think when saving to xls LO corrupts the xls file format.
Comment 1 a07cd040897db54e103c 2014-03-12 15:44:55 UTC
Created attachment 95671 [details]
The file saved as *.xls with Calc 4.2.1.1
Comment 2 a07cd040897db54e103c 2014-03-12 17:02:55 UTC
(In reply to comment #1)
> Created attachment 95671 [details]
> The file saved as *.xls with Calc 4.2.1.1

Just tested with 4.2.2.1 prerelease and there the bug seems to be fixed.
Comment 3 m.a.riosv 2014-03-12 23:11:08 UTC
I think this is a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=74345, please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 74345 ***