Bug 76164 - [Firebird] Import tables from ODS with more then 10 columns fails
Summary: [Firebird] Import tables from ODS with more then 10 columns fails
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.3.1 rc
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Database-Import
  Show dependency treegraph
 
Reported: 2014-03-14 10:06 UTC by wabik
Modified: 2017-10-23 08:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Firebird_Base_more_10_rows (53.03 KB, text/vnd.oasis.opendocument.database)
2014-03-14 10:06 UTC, wabik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wabik 2014-03-14 10:06:43 UTC
Created attachment 95787 [details]
Firebird_Base_more_10_rows

1. Create ODS file with more than 10 rows
2. Create Firebird database
3. Import ODS Sheet into database tables by dragging ODS sheet into Base tables.
4. If the table has more than 10 rows opening fails if less, Base opens table.

See attachment.

Using HSQLDB everything seems to be ok.
Comment 1 wabik 2014-03-14 10:09:24 UTC
If more then 10 rows, one can get an error:

firebird_sdbc error:
*Dynamic SQL Error
*SQL error code = -804
*Incorrect values within SQLDA structure
caused by
'isc_dsql_fetch'
Comment 2 Alex Thurgood 2014-03-14 15:15:39 UTC
Can not confirm that it is the number of rows which is the problem on my Linux master 4.3 build with a test Calc sheet imported into an empty Firebird ODB containing 20 or more rows.

The problem is more likely to lie in the field definition or the character strings of your varchar fields.

Can you post your ODS file so we can test ?

Alex
Comment 3 Alex Thurgood 2014-03-14 15:25:43 UTC
Any relation to bug 74019 ?


Alex
Comment 4 wabik 2014-03-17 06:16:27 UTC
Alex,

ODS is uploaded ... with two tables one which contains 10 rows and one which more than 10 rows ...

Brgds,
Piotr
Comment 5 wabik 2014-03-17 06:19:40 UTC
Could be the duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=74019
Comment 6 wabik 2014-03-17 06:44:23 UTC
Sorry I made a mistake ... my bad! 
Not rows but columns! More than 10 columns make and error ...
Comment 7 Julien Nabet 2014-05-31 14:43:41 UTC
wabik: Following this comment https://bugs.freedesktop.org/show_bug.cgi?id=74019#c7, could you give a try to 4.2.5 or 4.2 daily build (see http://dev-builds.libreoffice.org/daily/libreoffice-4-2/) ?
Comment 8 wabik 2014-06-02 05:55:27 UTC
Tested on LO 4.2.5.1 ... still not working :(

Table is imported but cannot be opened.

Error:

Kod błędu: 1

firebird_sdbc error:
*Dynamic SQL Error
*SQL error code = -804
*Incorrect values within SQLDA structure
caused by
'isc_dsql_fetch'
Comment 9 Julien Nabet 2014-06-04 20:45:56 UTC
On pc Debian x86-64 with 4.2.4 LO version, I can reproduce this.
I don't reproduce this with 4.2 sources updated some days ago.

Wabik: for the test, could you give a try to the daily 4.2 build (future 4.2.6)?
Comment 10 wabik 2014-06-05 06:31:48 UTC
Version: 4.2.6.0.0+
Build ID: 743bcdebef21deeb73f0111b4e6e047c88fd7b8f
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-06-04_14:23:07

The same error:

Error code: 1

firebird_sdbc error:
*Dynamic SQL Error
*SQL error code = -804
*Incorrect values within SQLDA structure
caused by
'isc_dsql_fetch'
Comment 11 Julien Nabet 2014-06-05 06:43:21 UTC
Thank you for your feedback, no idea then :-(.
Comment 12 Alex Thurgood 2014-06-06 09:42:23 UTC
Confirming also on OSX with LO 4242, changing OS to all
Comment 13 Julien Nabet 2014-07-02 20:23:59 UTC
Wabik/Alex: Following the fix of fdo#74019, would you have some time to give a try to a recent (less than 3 weeks ago) 4.2 daily build?
Comment 14 Popa Adrian Marius 2014-07-04 12:22:38 UTC
Seems that git push for fdo#74019 fixes this bug also 

I have tested with a sheet > 20 rows as described above and no crashes 

libo Version: 4.4.0

So this can be closed
Comment 15 Julien Nabet 2014-07-04 12:43:46 UTC
Thank you for the feedback.
So let's put this as FIXED

Wabik/Alex: Don't hesitate to reopen this tracker, if you can still reproduce this.
Comment 16 Popa Adrian Marius 2014-07-04 12:55:14 UTC
Thanks for closing it 

also i have tested with more than 10 columns and seems to be stable: nocrashes :)