Bug Hunting Session
Bug 76227 - Other: Problem with last version report, and now latest which isn't listed in menu above
Summary: Other: Problem with last version report, and now latest which isn't listed in...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 75391 77357 79899 81983 (view as bug list)
Depends on:
Blocks: Installer-Linux
  Show dependency treegraph
 
Reported: 2014-03-16 08:34 UTC by Michael Setzer II
Modified: 2018-01-17 17:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Setzer II 2014-03-16 08:34:47 UTC
Problem description: 
Added problem, you pull down menus don't include the latest versions...

Steps to reproduce:

Downloaded the Updated files and extracted both separate files, and extracted them. Changed to the RPMS directory to update, and it fails with the dependencies.

[root@setzco LibreOffice_4.2.2.1_Linux_x86-64_rpm]# cd RPMS/
[root@setzco RPMS]# rpm -Uvh *.rpm
error: Failed dependencies:
	libobasis4.2-en-US <= 4.2.1.1-1 is needed by (installed) libobasis4.2-en-US-help-4.2.1.1-1.x86_64

Copied the Help RPM from the helppack RPM from the other directory.

[root@setzco RPMS]# cp /home/msetzerii/data/LibreOffice_4.2.2.1_Linux_x86-64_rpm_helppack_en-US/RPMS/*.rpm .

Reran the update, and now it works fine.

[root@setzco RPMS]# rpm -Uvh *.rpm
Preparing...                ########################################### [100%]
   1:libreoffice4.2-ure     ########################################### [  2%]
   2:libobasis4.2-core01    ########################################### [  4%]

Current behavior:
Doesn't work to Install as past versions did.
Past Versions would install the program, and then run the update the helppack.

Expected behavior:

Either the same as past, or just included the helppack in the install to make it work.
              
Operating System: Fedora
Version: 4.2.1.1 release
Comment 1 Buovjaga 2014-11-05 12:21:55 UTC
*** Bug 79899 has been marked as a duplicate of this bug. ***
Comment 2 Buovjaga 2014-11-05 12:30:12 UTC
*** Bug 75391 has been marked as a duplicate of this bug. ***
Comment 3 Buovjaga 2014-11-05 12:31:39 UTC
*** Bug 77357 has been marked as a duplicate of this bug. ***
Comment 4 Todd 2014-11-18 01:31:24 UTC
Okay, now this is embarrassing.  I posted the following over on Red Hat for LibreCAD:

https://bugzilla.redhat.com/show_bug.cgi?id=1113380#c5
    $ su root -c "rpm -Uvh LibreOffice_4.3.4.1_Linux_x86-64_rpm/RPMS/*.rpm"
    Password: 

    error: Failed dependencies:
            libobasis4.3-en-US <= 4.3.3.2-2 is needed by (installed) libobasis4.3-en-US-help-4.3.3.2-2.x86_64

    But it is not missing:
          $ rpm -qa libobasis4.3-en-US
          libobasis4.3-en-US-4.3.3.2-2.x86_64

    That sure look "<= 4.3.3.2-2" to me.



And they answered me (what a bunch of nice guys)!

https://bugzilla.redhat.com/show_bug.cgi?id=1113380#c6

     I'm really not sure how you ended up here, this is a closed bug on
     Librecad (not LibreOffice). That said, I'm going to try to guess at
     your issue:

     You're updating from a directory full of rpms for LibreOffice
     4.3.4.1. What the error is saying is that in the transaction,
     libobasis4.3-en-US gets updated from 4.3.3.2 to 4.3.4.1, but
     libobasis4.3-en-US-help does not, leaving it with an unresolved
     dependency on the old libobasis4.2-en-US (4.3.3.2), and failing
     the transaction (because you don't want broken dependencies).

     I would look in that directory and see if libobasis4.3-en-US-help
     is in there, I suspect it is missing. If that package went away
     in 4.3.4.1, it _should_ have been properly Provided/Obsoleted by
     something else in the package set (likely libobasis4.3-en-US),
     but since that clearly isn't happening, you might have to manually
     remove libobasis4.3-en-US-help before trying to update again:

     su root -c "rpm -e libobasis4.3-en-US-help"


Is there something here that will help you guys?

Many thanks,
-T

But I'm betting that package is still there and just didn't get downloaded into your directory for some reason.

Hope that helps.
Comment 5 Joel Madero 2014-11-20 05:38:55 UTC
*** Bug 81983 has been marked as a duplicate of this bug. ***
Comment 6 Robinson Tryon (qubit) 2015-01-24 14:43:11 UTC
(In reply to Todd from comment #4)
>      You're updating from a directory full of rpms for LibreOffice
>      4.3.4.1. What the error is saying is that in the transaction,
>      libobasis4.3-en-US gets updated from 4.3.3.2 to 4.3.4.1, but
>      libobasis4.3-en-US-help does not, leaving it with an unresolved
>      dependency on the old libobasis4.2-en-US (4.3.3.2), and failing
>      the transaction (because you don't want broken dependencies).

AFAIK helppacks and langpacks are distributed separately from the primary bundle of a LibreOffice installer. Example:
http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86@45-TDF/current/

master~2015-01-20_16.05.21_LibreOfficeDev_4.5.0.0.alpha0_Linux_x86_rpm.tar.gz
master~2015....rpm_helppack_en-US.tar.gz
master~2015....rpm_langpack_en-US.tar.gz
master~2015....rpm_sdk.tar.gz  

If the help was installed with a dependency on 4.3.4.1, I'd imagine that removing 4.3.4.1 would also remove any dependent packages that didn't have available upgrades (e.g. 4.3.4.1-help). You mentioned that past versions upgraded the help as well -- were those updates from RH or from LO servers?
Comment 7 Michael Setzer II 2015-01-24 15:16:03 UTC
This is with the released updates from LibreOffice site. Extracting all of the released updates for some time now fails as is. You extract the main one, and it will not install due to the dependence. Simply copying the rpm file from the help archive into the same directory as all the others, and the running the update works just fine. I guess one could go thru the process on uninstalling the program and the help, and then manually doing the update of the program and then the help. But why put out something that doesn't just work. Why not just include the help file in the batch as one simple package.
Comment 8 Todd 2015-01-30 21:38:25 UTC
(In reply to Michael Setzer II from comment #7)
> Why not just include the help file in the batch as one
> simple package.

1+

Look what just worked:

rpm -Uvh LibreOffice_4.4.0.3_Linux_x86-64_rpm_helppack_en-US/RPMS/libobasis4.4-en-US-help-4.4.0.3-3.x86_64.rpm LibreOffice_4.4.0.3_Linux_x86-64_rpm/RPMS/*.rpm

Installed perfectly
Comment 9 Michael Meeks 2015-02-19 15:29:55 UTC
The dependency is designed to avoid installing a new LibreOfffce with an old help-pack. If you want to upgrade core LibreOffice, you will need to download the separate (to save download size - those things are in aggregate 100's of Mb small) help pack that you previously installed and upgrade both in tandem.

Looks like this works as designed, but perhaps I'm missing something.
Comment 10 Todd 2015-02-19 16:52:43 UTC
(In reply to Michael Meeks from comment #9)
> The dependency is designed to avoid installing a new LibreOfffce with an old
> help-pack. If you want to upgrade core LibreOffice, you will need to
> download the separate (to save download size - those things are in aggregate
> 100's of Mb small) help pack that you previously installed and upgrade both
> in tandem.
> 
> Looks like this works as designed, but perhaps I'm missing something.

Hi Michael,

What yo are missing is that installing and upgrade should abe just that.  No trouble shooting, no research, no work arounds, no "rpm --nodeps" should be involved.  This bug should not be closed until you accomplish that.

I see two ways of doing that, 1) include both together, or 2) remove the dependency.

Many thanks,

-T
Comment 11 Michael Setzer II 2015-02-19 21:21:26 UTC
If it is a design issue, then it is not consistent, since the Windows version installs the new version with no problem when an old help file is installed? So, why does the linux version not work. The help back is only 6M, so either including it in the original package, or making it not required like windows?
I generally, always install it on both, but windows doesn't require it?

At the moment, one has to download both program and help file, and copy the help file rpm file into the program RPMS directory, and then do rpm -Uvh *.rpm, or perhaps uninstall the program and help files, and then reinstall them separately. 

Think may users would try to install, and when they get the dependency error just give up.
Comment 12 Michael Meeks 2015-02-26 21:06:12 UTC
Hi Michael, (nice name incidentally) :-)

> If it is a design issue, then it is not consistent, since the Windows
> version installs the new version with no problem when an old help file
> is installed ?

Consistency with windows - which has no even half-way decent package management or dependency setup at all is not really a goal. As & when Windows has a sane package management system it's an option of course.

> So, why does the linux version not work.

Au contraire - it does work =) Then again - if -you- want to help patch this issue things change: people with real, tested code changes can make a difference. I have some sympathy with the idea that the help doesn't really change that significantly across minor versions; so potentially loosening the requirement there might be helpful. But code first; not bug status wars - which just irritate people.

> The help back is only 6M, so either including it in the original package,
> or making it not required like windows ?

Ethnocentricty is not a crime; but why would your language (of 100+) be privileged to be bundled in the original package - if you multiply the 'only 6Mb' by >100 languages, you have over half a Gb. That is not attractive to tack onto the existing ~200Mb package. Of course, we could up-load 100's of Gb by having separate packages for each language - but this is a scalability, up-load efficiency, and then server/mirror utilization disaster area. That's why we don't do it ;-)

> I generally, always install it on both, but windows doesn't require it?

There should be no need to install the help; you can use on-line wiki-help in either case.

> At the moment, one has to download both program and help file, and copy
> the help file rpm file into the program RPMS directory, and then do
> rpm -Uvh *.rpm, or perhaps uninstall the program and help files, and
> then reinstall them separately. 

Sure - so manual package management on Linux sucks to the point that only some tiny fraction of our users bother to not use their distro packaging, some even smaller set bother to install the on-line help - this is a corner-case.

> Think may users would try to install, and when they get the dependency
> error just give up.

Again - I think its unlikely; but I'm glad you're concerned about this use-case. I imagine fixing it is a matter of reading up on the public EPM docs, and then wrestling with the EPM packaging code and-or solenv/bin/make_installer.pl and it's spawn. I'd love to see a patch to slightly relax the dependency (it will still affect people updating through x.y versions though) - but lets leave this bug closed until then.

Thanks for your feedback.
Comment 13 Michael Setzer II 2015-02-27 01:32:50 UTC
I can see your points, but one thing that would make it much better from my point would be to make the help file, so that it would extract the file into the same RPMS directory as the full update. As it is, one has to extract the Main update, and then extract the Help, and then copy the Help RPM into the directory. If help was setup to use the same directory, one could just extrat the two files, and then run rpm -Uvh *.rpm and it is done. 

Just downloaded the new version, and did these steps.

tar -zxvf LibreOffice_4.4.1_Linux_x86-64_rpm.tar.gz
tar -zxvf LibreOffice_4.4.1_Linux_x86-64_rpm_helppack_en-US.tar.gz 
cp LibreOffice_4.4.1.2_Linux_x86-64_rpm_helppack_en-US/RPMS/libobasis4.4-en-US-help-4.4.1.2-2.x86_64.rpm LibreOffice_4.4.1.2_Linux_x86-64_rpm/RPMS/
cd LibreOffice_4.4.1.2_Linux_x86-64_rpm/RPMS
rpm -Uvh *.rpm
Comment 14 Todd 2015-02-27 01:40:40 UTC
(In reply to Michael Setzer II from comment #13)
> I can see your points, but one thing that would make it much better from my
> point would be to make the help file, so that it would extract the file into
> the same RPMS directory as the full update. As it is, one has to extract the
> Main update, and then extract the Help, and then copy the Help RPM into the
> directory. If help was setup to use the same directory, one could just
> extrat the two files, and then run rpm -Uvh *.rpm and it is done. 
> 
> Just downloaded the new version, and did these steps.
> 
> tar -zxvf LibreOffice_4.4.1_Linux_x86-64_rpm.tar.gz
> tar -zxvf LibreOffice_4.4.1_Linux_x86-64_rpm_helppack_en-US.tar.gz 
> cp
> LibreOffice_4.4.1.2_Linux_x86-64_rpm_helppack_en-US/RPMS/libobasis4.4-en-US-
> help-4.4.1.2-2.x86_64.rpm LibreOffice_4.4.1.2_Linux_x86-64_rpm/RPMS/
> cd LibreOffice_4.4.1.2_Linux_x86-64_rpm/RPMS
> rpm -Uvh *.rpm

This worked for me:

rpm -Uvh LibreOffice_4.4.1.2_Linux_x86-64_rpm_helppack_en-US/RPMS/libobasis4.4-en-US-help-4.4.1.2-2.x86_64.rpm LibreOffice_4.4.1.2_Linux_x86-64_rpm/RPMS/*.rpm

I get this, but I am a computer professional.  A standard user would be beside himslef.
Comment 15 Xisco Faulí 2018-01-17 17:08:34 UTC
This bugs was never confirmed by a third person, besides, mmeeks set it as RESOLVED NOTABUG. Putting it back to that status