Bug Hunting Session
Bug 76443 - error linked cell
Summary: error linked cell
Status: RESOLVED DUPLICATE of bug 75386
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-21 11:12 UTC by bfede
Modified: 2014-03-22 12:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
file calc with error (372.71 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-03-21 11:12 UTC, bfede
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bfede 2014-03-21 11:12:22 UTC
Created attachment 96153 [details]
file calc with error

I apologize for the English translated automatically. 
In the sheet after moving a group of elements to include other functions or noticed that some links while being correct (in the formula is the reference to the cell right) are not retained (ece v 0 is displayed in the correct number). I attach a sheet with this error in which the cell with the error is shown in red. potytrebbero there will be others but I have not checked all the connections but I scored comunuque the two most obvious. This thing is going to move repeats of elemnti already linked cell, the program is not capable of correctly and always follow the formulas and cells connected
Comment 1 m.a.riosv 2014-03-21 23:42:55 UTC
Ciao bfede, thanks for reporting.

I can only see that in
N16: =(-K16+(K16^2+L16*K16)^0,5)/M16
but M16 is zero, so results in a error #DIV/0!. but this is not a bug by itself.

Maybe you can find better help in the Italian Mailing list.
http://nabble.documentfoundation.org/Italian-f1816772.html
Comment 2 bfede 2014-03-22 11:33:30 UTC
The problem lies in Q5 which is equal to 0 even if it is connected to the E23 which is equal to 3150, the error is generated after moving the block "Verifica statica" (A20:J14), from A16:J40 to A20: J44. If I put myself in Q5 I click and move the reference E23, E23 moving it and then bring it back all right. This is a mistake because the program should follow any movement of cells into cells and maintain the correct reference value (in this case Q5 = 3150)(In reply to comment #1)
Comment 3 m.a.riosv 2014-03-22 12:42:53 UTC
I see now.

A hard recalc [Ctrl+Shift+F9] do the calculations.

Drag issue has been solved for 4.2.3 with https://bugs.freedesktop.org/show_bug.cgi?id=75386, you can find the new version in:
http://downloadarchive.documentfoundation.org/libreoffice/old/?C=M;O=D
But first time after open you need to do a hard recalc [Ctrl+Shift+F9].

*** This bug has been marked as a duplicate of bug 75386 ***