Download it now!
Bug 76456 - FILEOPEN custom shape itself and text in custom shape have wrong rotation
Summary: FILEOPEN custom shape itself and text in custom shape have wrong rotation
Status: VERIFIED DUPLICATE of bug 83593
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OOXML-Shapes Shapes-Custom
  Show dependency treegraph
 
Reported: 2014-03-21 14:49 UTC by Regina Henschel
Modified: 2020-09-14 07:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
custom shape rotated, text rotated (26.72 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-03-21 14:49 UTC, Regina Henschel
Details
3.3.4 (1.11 MB, image/bmp)
2016-11-02 00:57 UTC, Richard
Details
5.2.2 (1.12 MB, image/bmp)
2016-11-02 00:58 UTC, Richard
Details
Screenshof of the example file in bibisect-7.1 repo (170.14 KB, image/png)
2020-08-28 08:44 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2014-03-21 14:49:31 UTC
Created attachment 96171 [details]
custom shape rotated, text rotated

The attached document contains three custom shapes. The left example has the default settings. The middle example is rotated by 90°, the text remains in the default orientation. The right example is rotated by 90° and in addition the whole text is rotated by 270°, which is one of the settings in Excel. All angle values are those from the UI. I have not looked, whether they are different in file format.
The file contains in addition a screenshot from the view in Excel 2010.

Open the file. Notice, that the rotated shapes are wrong.

Notice, that for a draw:custom-shape the draw:enhanced-geometry has an attribute draw:text-rotate-angle, which would be responsible for the text rotation. The shape rotation is done by a transformation.
Comment 1 Buovjaga 2014-11-08 14:43:43 UTC
I confirm the wrongness.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: c989f5e0e11e295b11ffc921b0d105869e037e47
TinderBox: Win-x86@42, Branch:master, Time: 2014-11-07_22:50:48
Comment 2 Xisco Faulí 2015-09-09 15:12:21 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2016-09-20 10:29:57 UTC Comment hidden (obsolete)
Comment 4 Richard 2016-11-02 00:54:54 UTC
CONFIRMED to be still present on Ubuntu 16.04 and LibreOffice 5.2.2. 

Shape and text orientation is wrong for second and third shape. 

Bug also present in LibreOffice 3.3.4. The orientation is fine except for the third shape where the text orientation is wrong.
Comment 5 Richard 2016-11-02 00:57:21 UTC
Created attachment 128420 [details]
3.3.4
Comment 6 Richard 2016-11-02 00:58:04 UTC
Created attachment 128421 [details]
5.2.2
Comment 7 QA Administrators 2017-11-03 08:05:15 UTC Comment hidden (obsolete)
Comment 8 Regina Henschel 2017-11-06 00:02:15 UTC
The error is still in Version: 6.0.0.0.alpha0+
Build ID: 6c68f38bc28bb55a4f0d53b8f38957516d3935d1
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-09-04_22:05:26
Locale: de-DE (de_DE); Calc: group
Comment 9 Regina Henschel 2018-11-06 15:03:34 UTC
The error is still in Version: 6.2.0.0.alpha1+ (x64)
Build ID: f825e6d4082c0d0beb1c95b881f6a2ee9bfc9161
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-05_00:20:26
Locale: de-DE (en_US); Calc: CL
Comment 10 Tamas Bunth 2019-11-05 14:46:31 UTC
On current master, the first shape seems to be wrong as well.

First shape:
- shape: 0° correct
- text: 270° instead of 0°

Second shape:
- shape: 0° instead of 90°
- text: 270° instead of 90°

Third shape:
- shape 0° instead of 90°
- text 270° correct

It seems to me that shape orientation is 0° no matter what and text is 270° no matter what. The first shape is slightly different from the two others though, because the text is wrapped elsewhere.

Version: 6.4.0.0.alpha0+
Build ID: f521ad80d8d32404bf587ff077181e529e277f21
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk3;
Comment 11 Tamas Bunth 2019-11-05 14:50:23 UTC
All the degrees above mean clockwise.
Comment 12 NISZ LibreOffice Team 2020-08-28 08:44:43 UTC
Created attachment 164787 [details]
Screenshof of the example file in bibisect-7.1 repo

This got solved with:

https://git.libreoffice.org/core/+/130e6a3f4493b987a7d0b177cc84d65219b47d13

author
Szabolcs Toth <szabolcs450@gmail.com> Thu May 21 09:06:08 2020 +0200 
committer
László Németh <nemeth@numbertext.org> Fri May 29 17:26:08 2020 +0200 

tdf#83593 XLSX DrawingML shape import: fix missing rotation
Comment 13 NISZ LibreOffice Team 2020-08-28 08:44:59 UTC

*** This bug has been marked as a duplicate of bug 83593 ***
Comment 14 NISZ LibreOffice Team 2020-09-14 07:33:16 UTC
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 34a09c9c61bff30e8c4d16132bb47b2b1b16e422
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded