Download it now!
Bug 76461 - Merged cells border format doesn't work when selecting a row
Summary: Merged cells border format doesn't work when selecting a row
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Border Calc-Merge-Split
  Show dependency treegraph
 
Reported: 2014-03-21 17:21 UTC by me
Modified: 2018-12-31 09:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description me 2014-03-21 17:21:01 UTC
I have several sheets that I want to add a border below row 2. I select all sheets and the row and use format cell borders.

The border is only added to the cells that aren't merged, not the row 1&2 merged cells.

Steps to reproduce:
1. Merge rows 1 & 2 in columns A-C.
2. Select row 2 and format cells>borders.
3. Select bottom border, 1.5 >ok

Expect a border across base of row 2 including merged cells.

Current only non merged cells have border.
NB if I select the cells and not row not a problem
Comment 1 A (Andy) 2014-03-21 20:52:29 UTC
reproducible with LO 4.2.2.1 (Win 8.1)
Comment 2 Joel Madero 2015-05-02 15:42:39 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-06-20 16:33:51 UTC
Repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 4 QA Administrators 2016-09-20 10:12:10 UTC Comment hidden (obsolete)
Comment 5 Timur 2018-12-24 17:23:36 UTC
While this request may seem logical for a specific wish adding a border below row 2, it's really not because what if you want to add some other borders or what happens if you want to change font size, no rule to know where it applies. 
This was confirmed too soon, without UX. 
I'll mark WontFix. 
If I'm wrong, I add UX to CC.
Comment 6 Heiko Tietze 2018-12-31 09:33:38 UTC
(In reply to Timur from comment #5)
> I add UX to CC.

Split here as I understand the use case but OTOH multiselection can easily harm the document. So the current behavior is kind of a safety solution. 

The OP may reopen the ticket.