Download it now!
Bug 76466 - Save as a different file format is now extremely awkward when using GTK3 dialog.
Summary: Save as a different file format is now extremely awkward when using GTK3 dialog.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-03-21 18:53 UTC by Kohei Yoshida
Modified: 2014-03-21 19:13 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kohei Yoshida 2014-03-21 18:53:59 UTC
This is a regression caused by Bug 74064.

While in Gnome 3, 

1. Open an existing ods document,
2. Go to File -> Save As, and make sure you have the GTK's native file dialog open.
3. Change the format type to anything other than ODS, say, Microsoft Excel (.xls).
4. Hit Save.

It still tries to save the document as the original ods document.
Comment 1 Kohei Yoshida 2014-03-21 18:54:18 UTC
regression
Comment 2 Kohei Yoshida 2014-03-21 19:13:30 UTC
I chose to revert the "fix" for fdo#74064 for now.