Download it now!
Bug 76509 - add check for updates item to QuickStarter right click menu
Summary: add check for updates item to QuickStarter right click menu
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Quickstarter
  Show dependency treegraph
 
Reported: 2014-03-23 14:07 UTC by lal
Modified: 2017-11-28 14:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot of Swedish quick start for LO 4.2.1 (8.69 KB, image/png)
2014-03-23 14:07 UTC, lal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lal 2014-03-23 14:07:57 UTC
Created attachment 96240 [details]
screen shot of Swedish quick start for LO 4.2.1

Problem description: 

Steps to reproduce:
1. right click on Quick start
2. Try to select option "check for updates"
3. Realise it is not part of the options available

Current behavior:
Not able to to check for updates unless starting one of the LO applications

Expected behavior:
Be able to right-click the quickstart icon in order to check for updates without starting one of the applications.
              
Operating System: Windows 8
Version: 4.2.1.1 release
Comment 1 retired 2014-03-23 15:03:46 UTC
WORKSFORME.

You post a screenshot of 4.1 but write you use 4.2.1.1 later.

In 4.2.2.1 I can go to menu > Help > Check for updates.
Comment 2 lal 2014-03-23 16:46:46 UTC
The resolution you suggest requires you to start the actual application, e.g. Write. The function missing refers to the quick start (quick launch?) icon found in the bottom right hand corner of windows screen. The screen shot is NOT from 4.1, it is from 4.2.1 in Windows 8.1 (all Swedish)
Comment 3 retired 2014-03-31 08:49:39 UTC
lal, which applications are you aware of, that check for updates without being open? Note that e.g. flash or java do run in the background and are thus able to check. Not sure if having a LO agent for updates is worth the effort. Also highly doubt that there's capacity for that.
Comment 4 lal 2014-03-31 18:45:49 UTC
Thank you for your updated note on this matter. 

The application I refer to is already running in the background at all times on the computer - it is the windows LO Quickstart application found in the bottom right hand corner of the task bar. 

The function requested is not that the application would automatically poll for new updates (as your reference to Java or Flash would indicate), so I am sorry that I am unclear on this. What I am aiming for is for the user to have the same functionality as s/he has for starting e.g. Write via the LO quick launch application: Right-click on the LO quicklaunch icon already active in the taskbar, and in the options made visible (see screen shot) a new one would be "Check for updates". That link would simply bring up the regular "check for updates" screen in LO.

Today I have to first start LO Write or the "LO general launch application" (neither of them are actively running in the task bar) to get access to the update check via the menu inside the application.

The suggested apporach would simplify updateing/upgrading to latest LO version for most (all?) MS windows LO users.

Hoping this has helped explain better - but if not, please let me know.
Comment 5 QA Administrators 2014-10-05 23:05:56 UTC Comment hidden (obsolete)
Comment 6 lal 2014-10-06 16:51:06 UTC Comment hidden (no-value)
Comment 7 tommy27 2014-10-20 09:29:30 UTC
edited summary notes to make clearer what the enhancement request is for
I set status to NEW

consider that QuickStarter has been temporarily disabled in LibO 4.3.2.2 but will be available again in forthcoming LibO 4.3.3.2 

the 4.2.x branch still has active quickstarter
Comment 8 Timur 2017-08-28 10:29:09 UTC
This was a mistake to set to New without UX. I'd say WontFix on this.
Comment 9 Heiko Tietze 2017-11-28 14:51:26 UTC
The quickstarter is heading south because it's suspicious for virus scanners and not a cross-plattform feature. Updates are better handled internally, meaning your get an infobar if there is a new release available. So any effort in this feature is futile.