Bug 76525 - Other: Letter Wizard of german LibreOffice installation creates US formatted letter
Summary: Other: Letter Wizard of german LibreOffice installation creates US formatted ...
Status: RESOLVED DUPLICATE of bug 75218
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-23 18:35 UTC by norbert.flatinger
Modified: 2018-01-13 21:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description norbert.flatinger 2014-03-23 18:35:22 UTC
This problem exists for me since LibreOffice 4.x. So for me any 4.x version is unusable and I still stick to 3.6.7.

Problem description: 
I have a german installation of LibreOffice on Windows XP (select only german language) and Debian testing (install german language packages and remove en-us language packages). Both have the same problem.
I start the letter wizard, select all I need and enter what I want. At the end the wizard always creates a US formatted document. The papersize is letter, the document language is en-us, the fold marks are US and so on. But I expect a german formatted document.
Unfortunately the combo box to select the country format is gone since version 4.x

Steps to reproduce:
1. start letter wizard
2. select and enter what you want or need
3. create letter

Current behavior:
creates US formatted letter document

Expected behavior:
should create german formatted letter dosument

Operating System: All
Version: 4.1.0.4 release
Comment 1 retired 2014-03-24 07:55:25 UTC
Confirmed:4.2.2.1:OSX

LO creates Letter Format page. That format is not used in germany or (if I recall correctly in Europe).

Paper format used for that wizard with one of those languages installed should indeed be DIN A4.

Valid enhancement request. NEW
Comment 2 Stephan Bergmann 2014-03-24 11:44:51 UTC
Probably a consequence of the fact that the letter wizard templates are no longer localised, as discussed in the mail thread around <http://lists.freedesktop.org/archives/libreoffice-ux-advise/2014-March/002872.html> "Letter Wizard behavior."
Comment 3 Joel Madero 2015-05-02 15:41:58 UTC Comment hidden (obsolete)
Comment 4 norbert.flatinger 2015-05-11 22:58:24 UTC
I just tried LibreOffice 4.4.3.2 on WinXP and I see absolutely no change in the bugs behaviour.
The combo box to select the country format on the 1st page of the letter wizard is still gone.
So I still have 3.6.7 in use.
Comment 5 norbert.flatinger 2015-05-11 23:26:11 UTC
I'm sorry. The combo box to select the "country format" of the letter is in the *3rd* step of the wizard in version 3.6.7.2 and it is missing since version 4.x.
Comment 6 QA Administrators 2016-09-20 09:42:17 UTC Comment hidden (obsolete)
Comment 7 norbert.flatinger 2016-10-13 20:59:40 UTC
I just tried LibreOffice 5.2.2.2 on Windows 8.1 (Home) 64-Bit and I still see absolutely no change in the bugs behaviour.
The combo box to select the country format on the 1st page of the letter wizard is still gone.
So I still have 3.6.7 in use.
Comment 8 QA Administrators 2017-10-23 13:57:30 UTC Comment hidden (obsolete)
Comment 9 norbert.flatinger 2017-11-22 21:00:10 UTC
Still absolutely no change in behaviour.
This is very sad. This bug is there for more than three and a half years now and absolutely nothing has happened.
I can't be the only person, who would like to use the letter wizard in Germany. So many people must be waiting for this feature to work again.
This nice and very useful - for me essential - feature was there, before version 4 was introduced. Why was it removed?
It should be easy to bring it back...

So I'm still stuck with the latest 3.x version, hoping to be able to upgrade to a usable actual version soon.

Regards,
Norbert
Comment 10 norbert.flatinger 2017-11-22 21:15:30 UTC
Sorry, I forgot to add the version information of the LO version I did my last test:

Version: 5.4.2.2
Build-ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
Comment 11 norbert.flatinger 2017-11-29 22:58:39 UTC
See also bug 75218!
I am not the only one with this huge and annoying problem!
Comment 12 Julien Nabet 2018-01-13 21:36:24 UTC

*** This bug has been marked as a duplicate of bug 75218 ***