Download it now!
Bug 76569 - Page number being reset to 1 after changing paragraph indents
Summary: Page number being reset to 1 after changing paragraph indents
Status: RESOLVED DUPLICATE of bug 79303
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: high blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-24 20:09 UTC by Joe Nicholls
Modified: 2014-10-22 05:01 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document after indents applied on page 2 (9.36 KB, application/vnd.oasis.opendocument.text)
2014-03-24 20:09 UTC, Joe Nicholls
Details
Libreoffice file saved as docx (18.34 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-06-17 17:53 UTC, George Kennaway
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Nicholls 2014-03-24 20:09:22 UTC
Created attachment 96314 [details]
Test document after indents applied on page 2

I create a document.  I then change the indent for some paragraphs.  the page after the page the indents are on starts with page number 1 again.

I have attached a three page document.  The test document is a simple 3 page document with the indents applied on page 2 and the page number of page 3 starts at one again.
Comment 1 sophie 2014-03-26 11:52:35 UTC
I cannot reproduce with Version: 4.2.3.1
Build ID: 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13, pages are correctly numbered.
Could you please test with the last version? left unconfirmed, lowering importance - Sophie
Comment 2 Joe Nicholls 2014-03-26 19:00:52 UTC
I downloaded version 4.2.3.1, build 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13.

The problem still exists.

The detailed reproduction steps are:

Steps to reproduce:
1.	create new text document.

2.	Type the following to create content in the document
Page 1<Enter>
<Enter>
<Enter>
<Ctl-Enter>	// to insert manual page break
Type Page 2<Enter>
<Enter>
a.<tab>a<Enter>
b.<tab>b<Enter>
c.<tab>c<Enter>
<Enter>
<Ctl-Enter>	// to insert manual page break
Type Page 3<Enter>
<Enter>
<Enter>

3.	From menu Insert -> Footer -> Default style

4.	Place cursor in foot just crated

5.	From menu Insert -> Fields -> PageNumber

6.	Page one will correctly show 1 in the page one footer
	Page two will correctly show 2 in the page one footer
	Page three will correctly show 3 in the page one footer
	
7.	Highlight the lines with a, b, and c on page number two

8.	While on page two grab the left pair of indent indicators (or 
        whatever they are called) on the top ruler and slide them to the
        0.5 mark on the ruller.  This will result in indenting the a, b, c 
        lines on page two 1/2 inch.
	
9.	Scroll down to the bottom of page three.  The page number in the
        page three footer will now wrongly show 1.
Comment 3 sophie 2014-03-27 09:33:11 UTC
Thanks for the steps to reproduce. I can confirm that after indenting the lines, the numbering on page 3 is reset to one. 
Set as New - Sophie
Comment 4 George Kennaway 2014-06-17 17:51:41 UTC
I'm constantly hitting this problem - I need to set all paras with 1st line indents 0.5 cm. No matter how I do this (para style, dragging indent tabs, setting a new tab...) sooner or later the page numbers reset to 1 after a few pages.
Comment 5 George Kennaway 2014-06-17 17:53:05 UTC
Created attachment 101260 [details]
Libreoffice file saved as docx
Comment 6 Vitaly 2014-06-21 18:52:33 UTC
Joe, thank You for reporting this bug. I confirm, that this bug is fully reproducible with your steps provided. 

Sophie, this bug must be marked also as high blocker, as for me - our company can not use any version newer than 4.0.6 despite many "tasty" enhancements made.
TOO many regressions, current 4.2.5 is not ready for enterprise deployments. This bug is the second blocker, after bug 70232 and bug 59428.
Comment 7 Vitaly 2014-07-31 17:15:33 UTC
Please add this BUG to list of Most Annoying Bugs, because it is. It is still not fixed in LO 4.3.0.4 (Win7). 

Impossible to use LO in production, especially in workgroups, 'cos most of people don't know that it's "prohibited" to use indents and brake page numbering.
Comment 8 colonelpanic42 2014-09-18 11:24:59 UTC
Confirm this is a bug on Fedora Linux 20 as well, running 4.2.6.3 from repositories. I've been able to reproduce on a new document, add a page number field somewhere convenient like the header, and then adjust indent with the ruler sliders.

Actually the bug seems to change effect (for me anyway) depending on what is already typed when the indent occurs. If there's nothing else on the document besides the page number fields, the page numbers get offset by -1 (so the first page becomes 0, the next 1, etc.). If there's some content first, the page numbers all become 1.

In my case though, I seem to be able to adjust the indents through the Paragraph settings without it breaking the page numbering.
Comment 9 tmacalp 2014-10-22 04:53:20 UTC
I just finished typing up a rather lenghty report before finding this report, so I'll just paste some of that here.  I'm pretty confident this is the same bug.

I've found the easiest way to trigger this bug is simply to manually adjust the "After Text" paragraph attribute.  You perform this action by sliding the gray upward-facing arrow found in the far-right of the top horizontal ruler.

Note that if you adjust this paragraph property by using the Format Paragraph dialog, the bug doesn't trigger.  It only triggers when you slide the arrow.  Also, saving and reloading the document recalculates the page numbers and fixes the bug.  This bug also affects table of contents page numbering and the TOC will store the erroneous numbers until updated.  Tools > Update > Update All Fields does not fix the issue.

Steps to reproduce:
1. Create a 5 page document with page numbers in the footer
2. On page 3, drag the gray upward-facing arrow found in the far-right of the top horizontal ruler to the left.

Expected results:
The page numbers in the footer of page 3, 4, and 5 should remain “3, 4, and 5.”

Actual results:
Page 3, the page we adjusted the “After Text” attribute on, now has changed the page number field in the footer to indicate that it's page 0.  Also, Writer's current page number in the Status Bar also lists this page as “Page 0/6”.  Oddly enough, it lists what should be page 4 as “Page 1  5/6” and page 5 as “Page 2  6/6”.

Alternatively, here is an even faster way to reproduce:
1. Create a new document
2. Drag the gray upward-facing arrow found in the far-right of the top horizontal ruler to the left
3. Note that your page number in the status bar has changed from "Page 1/1" to "Page 0/2"

I can confirm this bug on the following systems:
LO 4.3.2.2 on 64bit Arch Linux
LO 4.2.6.2 on 64bit RHEL
LO 4.2.0.4 on 32bit Fedora17

I can confirm that this bug does NOT affect the following:
LO 4.1.3.2 on 32bit Fedora17
LO 4.0.6.2 on 32bit Fedora17

I could also bibisect this bug if that helps.  Since I can replicate using 32bit and 64bit Linux, I'll change it from 64bit Windows to All.  Also, I'll change the version back to the first confirmed version that shows this bug.
Comment 10 tmacalp 2014-10-22 05:01:15 UTC
It looks like this is a duplicate of bug 79303.  I'll mark it as such.

*** This bug has been marked as a duplicate of bug 79303 ***