Bug 76636 - Crash in .doc when trying to merge cells
Summary: Crash in .doc when trying to merge cells
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: All All
: high critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.5.0 target:4.4.1 target:4.3....
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2014-03-26 13:41 UTC by Hermann Rochholz
Modified: 2019-04-13 12:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
example doc to reproduce the crash; Try to connect the right cells (13.50 KB, application/msword)
2014-03-26 13:41 UTC, Hermann Rochholz
Details
1st step (13.01 KB, image/jpeg)
2014-06-03 12:32 UTC, Hermann Rochholz
Details
2nd Step - when I click the button LO is "closed" (28.97 KB, image/jpeg)
2014-06-03 12:33 UTC, Hermann Rochholz
Details
installation error log (166.28 KB, text/plain)
2014-06-05 18:45 UTC, Hermann Rochholz
Details
screenshot of installation GUI (70.11 KB, image/jpeg)
2014-06-06 10:50 UTC, Hermann Rochholz
Details
Screenshot of Debugger Crash - The last info; Then in the bottom line there's "wait" and the window is away (92.76 KB, image/jpeg)
2014-06-08 09:44 UTC, Hermann Rochholz
Details
Here the three files usually sent to Microsoft (crashreport) (128.12 KB, text/plain)
2014-06-08 09:47 UTC, Hermann Rochholz
Details
windbg trace (23.12 KB, text/plain)
2014-06-09 16:14 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hermann Rochholz 2014-03-26 13:41:43 UTC
Created attachment 96415 [details]
example doc to reproduce the crash; Try to connect the right cells

Windows 7, Version: 4.2.0.2
Build-ID: cd65d6220c5694ee7012d7863bcde3455c9e3c30
german Version

OK: If a one has a document in doc-format(only this) 
and there is a table and you make "Zellen Verbinden" 
("connect cells" or similar) then there is an immediate crash. 

Probably there's an error in the document, 
but I think a crash is not the correct way.
If it's saved in odt the crash is away. 
Originally the document is coming from an rtf from an OCR-software.
Comment 1 Yousuf Philips (jay) (retired) 2014-05-31 14:48:05 UTC
Confirmed in Linux Mint in the latest releases from 3.6 to 4.2 and 4.3 beta.

I couldnt reproduce the crash by merging the cells, but could crash it by undoing the merge

Steps to reproduce:
1) open crash.doc
2) merge the cell with 'punteggio per corso (valutazione singola)' in it with the empty cell to its right
3) press undo
Comment 2 Hermann Rochholz 2014-05-31 17:43:17 UTC
OK- 
1) I mean the very right (hidden) cells. (the three top cells on the right)
Not the cells where text is in.
2) It's only a Windows-problem! 
Under Opensuse 13.1 64 bit and the actual Libreoffice there's no problem. 
Under Windows 7 with Libreoffice writer 4.2.4.2 there's again the crash.

Hermann
Comment 3 Yousuf Philips (jay) (retired) 2014-06-03 00:55:51 UTC
Unfortunately, i'm unable to confirm this on Windows 7 with LibO 3.6, 4.0, 4.2, and 4.4. Is it possible that you could send in a screencast of the crash?
Comment 4 Hermann Rochholz 2014-06-03 12:32:38 UTC
Created attachment 100356 [details]
1st step
Comment 5 Hermann Rochholz 2014-06-03 12:33:57 UTC
Created attachment 100357 [details]
2nd Step - when I click the button LO is "closed"
Comment 6 Yousuf Philips (jay) (retired) 2014-06-03 13:49:16 UTC
Thanks for the screenshots, but unfortunately it doesnt crash for me.
Comment 7 Yousuf Philips (jay) (retired) 2014-06-03 13:50:19 UTC
Is there any other information that you can provide to why it is crashing.
Comment 8 Hermann Rochholz 2014-06-03 16:18:43 UTC
Hallo Jay! No, sorry- I have here a simple Samsung Laptop with AMD core A 8 (as I remember) and Win7 Home premium. 
And to reproduce the crash I download my own file and do what I've shown to you. 
Is there any debug lib I can load?
Comment 9 Yousuf Philips (jay) (retired) 2014-06-03 23:34:50 UTC
You can find details about sending in debug information at the following links < https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows > and < https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg >.
Comment 10 Hermann Rochholz 2014-06-04 19:33:11 UTC
Now I tried the installation of the debugger:
https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
"Windows XP, Vista, 7 Users : Install Microsoft Windows SDK for Windows 7 and .NET Framework 4
direct link: http://www.microsoft.com/en-us/download/confirmation.aspx?id=8279
During the installation, which requires Microsoft .NET Framework 4 to be installed, uncheck all other options except for 'Debugging Tools for Windows'."
OK- Easy - klicking and unchecking like it's told; And then:
"Start WinDbg (X86)". I searched the start menue and then whole C:-Disk - but no WinDbg. Where is the binary located?
Comment 11 Yousuf Philips (jay) (retired) 2014-06-04 20:03:45 UTC
Check the start menu for the folder 'Debugging Tools for Windows', which should contain WinDbg in it. If it isnt present, then please re-run the installer as it is possible that it wasnt installed ( this happened to me as well just yesterday :) ). If you get lost during the process found in the wiki, you can watch this following video - http://youtu.be/fppBTs215yc
Comment 12 Hermann Rochholz 2014-06-05 18:31:37 UTC
Hello! before your answer I had installed already 2 times. 
During Installation Installer tells that the installation is placed in:
C:\Program Files\Microsoft SDKs\Windows\v7.1
But there is no Microsoft SDKs- 
Ah OK: It's needed to "execute as administrator" the install-routine.  
No error message, nothing. Windows-business as usual, already the error-messages are wrong...
Comment 13 Hermann Rochholz 2014-06-05 18:45:12 UTC
Created attachment 100484 [details]
installation error log
Comment 14 Hermann Rochholz 2014-06-05 18:46:49 UTC
The Folder was created, but then removed.
-------------------------
A problem occurred while installing selected Windows SDK components.

Installation of the "Microsoft Windows SDK for Windows 7" product has reported the following error: Please refer to Samples\Setup\HTML\ConfigDetails.htm document for further information.

Please attempt to resolve the problem and then start Windows SDK setup again. If you continue to have problems with this issue, please visit the SDK team support page at http://go.microsoft.com/fwlink/?LinkId=130245.
Comment 15 Yousuf Philips (jay) (retired) 2014-06-05 21:40:06 UTC
It seems that you will need to uninstall 'Visual C++ 2010 Redistributable' from your system as mentioned in < http://stackoverflow.com/questions/19366006/error-when-installing-windows-sdk-7-1 > and < http://social.msdn.microsoft.com/forums/windowsdesktop/en-us/8f3350f9-0b47-40ae-b070-f2ccbf041875/windows-7-sdk-installation-failure >.
Comment 16 Hermann Rochholz 2014-06-06 10:50:25 UTC
Created attachment 100516 [details]
screenshot of installation GUI

I made an "error" because I did not uncheck all other things except the debug tools like described. But sorry- it was out of my imagination  that anybody can provide an installation tool for several different tools where one is inhibiting the installation of the other. Thank you- and check out the screen shot...
Now the installation worked.
Comment 17 Yousuf Philips (jay) (retired) 2014-06-06 12:49:23 UTC
Yes, unfortunately they dont have a stand alone installer just for the debugging tools. If you have any problems with the rest of the process, you can check out this video < http://www.youtube.com/watch?v=fppBTs215yc >.
Comment 18 Hermann Rochholz 2014-06-06 20:27:15 UTC
Hallo Jay!
What I did: I ran Windbg-
have copied-paste 
CACHE*C:\symbols;SRV*http://dev-downloads.libreoffice.org/symstore/symbols;SRV*http://msdl.microsoft.com/download/symbols 
(I also tried the other path) 
from the manual being the page you sent me
Then attached soffice.bin to the process-
A window opens like in the movie- and then the debugger crashes.... 
------------------------------------------------------------
Dateien, die bei der Beschreibung des Problems hilfreich sind:
  C:\Users\Hermann Rochholz\AppData\Local\Temp\WER5550.tmp.WERInternalMetadata.xml
  C:\Users\Hermann Rochholz\AppData\Local\Temp\WER7733.tmp.appcompat.txt
  C:\Users\Hermann Rochholz\AppData\Local\Temp\WER780E.tmp.WERDataCollectionFailure.txt
.......
------------------
I had a "process lasso" inbetween, but this was not the reason. 
I fear that's it- a recursive debug will not be possible....
-----
I am not allowed to go to http://dev-downloads.libreoffice.org/symstore/symbols/
is this correct? (403 Forbidden)
Hermann
Comment 19 Yousuf Philips (jay) (retired) 2014-06-06 22:31:08 UTC
Hi Hermann,

I noticed the same 403 issue but had been advised to ignore it and stick with using the other copy and paste line instead - "CACHE*C:\symbols;SRV*http://dev-builds.libreoffice.org/daily/master/Win-x86@39/symbols;SRV*http://dev-downloads.libreoffice.org/symstore/symbols;SRV*http://msdl.microsoft.com/download/symbols". Please try it with one more time, and if it the debugger crashes again, please let me know and i'll have someone more knowledgable help out.
Comment 20 Hermann Rochholz 2014-06-07 10:59:29 UTC
Sorry, no way.
It ended with the line "int 3", then waiting and then crashing.
Every process I want to attach ends in a crash. 
I also tried to open the executable directly. Always "int 3" and then crash. 

I tried I think also the path you provided me before- this was the 2nd option in the manual you provided the link. 

The next joke of windbg:
Now additionally I tried to put a source path in- this didn't work, too. 
Then I wanted to remove it - no way! Now Windbg wants to have any string there. 
Before I had put it in it worked without.
Comment 21 Yousuf Philips (jay) (retired) 2014-06-07 12:20:31 UTC
Hi Hermann,
Can you do a screencast of whats happening with either camstudio or screencast-o-matic.com and upload it to any online file hosting service like dropbox, google drive or onedrive and then provide its link, so that i can hopefully give you some suggestions. In the screencast, start from your desktop, open up windbg and libreoffice, then in windbg open 'symbol file path' and then 'attach to a process'.
Comment 22 Hermann Rochholz 2014-06-08 09:44:33 UTC
Created attachment 100646 [details]
Screenshot of Debugger Crash - The last info; Then in the bottom line there's "wait" and the window is away
Comment 23 Hermann Rochholz 2014-06-08 09:47:05 UTC
Created attachment 100647 [details]
Here the three files usually sent to Microsoft (crashreport)

In fact there is no more info than the screenshoot and the three files (I put it into one). One file is an xml and the others are txt-files.
Kind regards hermann
Comment 24 Hermann Rochholz 2014-06-08 10:11:06 UTC
OH- by playing around once the debugger did not crash.
I cannot reproduce fully- this are the last lines.
---------
(488.7b0): Break instruction exception - code 80000003 (first chance)
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\windows\SYSTEM32\ntdll.dll - 
ntdll!DbgBreakPoint:
00000000`77930590 cc              int     3
--------
IMO there is the problem of not accessing the symbol file path:
When I go to http://dev-downloads.libreoffice.org/symstore/
then I can acess- here one finds the dir "symbols" which is needed to debug; and there is the
403 Forbidden nginx/1.2.1 -error. 
e.g the access to 
http://dev-builds.libreoffice.org/daily/master/Win-x86@39/symbols
is not a problem; And the Msoft symbol table does also not provide a problem to access. Hmm- what do you think? 
Hermann
Comment 25 pierre-yves samyn 2014-06-09 16:13:30 UTC
Hi

I reproduce on windows 7/64 & Version: 4.2.5.1
Build ID: 881bb88abfe2992c6cede97c23e64a9885de87de

I try to join a windbg trace...

Regards
Pierre-Yves
Comment 26 pierre-yves samyn 2014-06-09 16:14:03 UTC
Created attachment 100754 [details]
windbg trace
Comment 27 Yousuf Philips (jay) (retired) 2014-06-09 16:22:51 UTC
Thanks Pierre-Yves for confirming it and providing the backtrace. I'm setting the status to new.
Comment 28 Hermann Rochholz 2014-06-09 16:51:52 UTC
Thank you Pierre-Yves; I was in dire straits to give the necessary infos with my strange windows-system.
Comment 29 Björn Michaelsen 2014-08-21 12:21:15 UTC
(This is an automated message.)

LibreOffice development currently prioritizes bugs with the so called MAB (most annoying bugs) -- as this bug has not run through that process (including writing a short rationale for this bug being a candidate and other who are watching the tracker bug silently approving that rationale etc.) its priority is set to high. Note this is effectively no change in the urgency assigned to this bug, as we are currently not making a difference between high and highest and severity is untouched.

You can find out more about MABs and how the process works by contacting libreoffice qa on irc:

 http://webchat.freenode.net/?channels=libreoffice-qa

The QA wiki page also gives you hints on how to get in contact with the team (if IRC fails you, your next best choice is the mailing list):

 https://wiki.documentfoundation.org/QA
Comment 30 Timur 2014-10-03 14:41:30 UTC
Finally, is there a bug here and how do we reproduce it?
Merging works normally for me in LO 4.2.6. 

(In reply to Jay Philips from comment #1)
> Confirmed in Linux Mint in the latest releases from 3.6 to 4.2 and 4.3 beta.
> 
> I couldnt reproduce the crash by merging the cells, but could crash it by
> undoing the merge
> 
> Steps to reproduce:
> 1) open crash.doc
> 2) merge the cell with 'punteggio per corso (valutazione singola)' in it
> with the empty cell to its right
> 3) press undo

This is sth. different: Bug 79569 - CRASH after undoing multi-line cell merge
Comment 31 Commit Notification 2015-02-13 09:53:19 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e1f4022b9ea7ae99a31773c445d8229ba3bdea93

Resolves: tdf#76636 crash on merging certain cells imported from a .doc

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 32 Commit Notification 2015-02-13 11:36:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a4c3a56d886574a0af14806a3a3f7683873136dd&h=libreoffice-4-4

Resolves: tdf#76636 crash on merging certain cells imported from a .doc

It will be available in 4.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 33 Commit Notification 2015-02-13 11:42:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a3c8e7deea306ba3efb513c8fa7311a995f7fc73&h=libreoffice-4-3

Resolves: tdf#76636 crash on merging certain cells imported from a .doc

It will be available in 4.3.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 34 Commit Notification 2015-02-20 09:16:42 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a8734b582b756476f74cd046268c7fd117e46f7&h=libreoffice-4-4-1

Resolves: tdf#76636 crash on merging certain cells imported from a .doc

It will be available in 4.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 35 Commit Notification 2018-12-20 15:58:00 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/cab88e6fa6ae810a853c57ab427de3a3691828d4%5E%21

uitest for bug tdf#76636

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.