Bug Hunting Session
Bug 76653 - EDITING: Icon needed for "Start from current slide"
Summary: EDITING: Icon needed for "Start from current slide"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Toolbars
  Show dependency treegraph
 
Reported: 2014-03-26 18:41 UTC by Anastasius
Modified: 2016-01-25 19:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample icon for 'start presentation from current slide' (224 bytes, image/png)
2014-04-10 17:00 UTC, Anastasius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anastasius 2014-03-26 18:41:14 UTC
When editing a long presentation in Impress, one often needs to try it in full-screen mode, e.g. to carefully check the animations, or to rehearse part of a talk.

Currently, one can have an icon in the presentation toolbar for 'Start from first slide (F5)'. There is no icon for 'Start from current slide (shift-F5)', which would be required to quickly access that function.
I could do it with shift-F5, but I don't remember all the shortcuts!
Comment 1 Thomas Hackert 2014-04-09 12:46:44 UTC
Hello Anastasius, *,
I think, you should add "Enhancement" or "Feature request" to the summary line, as this is something, what you want get added, not really a bug ... ;)

If you really want such a feature, you can use a workaround instead:

1. Start Impress
2. Go to "Tools – Customize..."
3. Change to the register "Toolbars"
4. Change the drop-down menu below "LibreOffice Impress Toolbars" to "Presentation"

You will see the entry "Start from current Slide" there.

5. Select this entry and click on "Add...". This will add the text to your presentation toolbar as well as to the field below.
6. Now select the entry "Start from current Slide below the header "Toolbar Content" and click on "Modify".
7. Click on "Change Icon..." below it.

Now you are able to assign an icon to this function and click on it in the toolbar ... ;) Or did you have anything different in mind?
HTH
Thomas.
Comment 2 Anastasius 2014-04-10 17:00:37 UTC
Created attachment 97172 [details]
sample icon for 'start presentation from current slide'

Can't use this as icon in Customize Toolbar>Modify>Change Icon>Import
Comment 3 Anastasius 2014-04-10 17:12:02 UTC
Hi Thomas,

for me, not having a suitable GUI for an essential feature is as bad as a bug. I think there is a good reason why powerpoint has an icon to start the slideshow at the current slide, not the first slide (one of the very few cases where I prefer the microsoft solution ;-)

I had a text item 'Start from current slide' in the presentation toolbar so far, but it takes a lot of space.
Your suggestion of adding an icon would be nice, but it did not work, see the remarks I wrote when adding a test icon. I tried 16x16-pixel png-files with 8 bits grayscale, 8-bits indexed colors, and RGB, none of them worked. The .png files do work in other programs or with Insert>Image>From File.

Anyhow, not everyone would like to create his or her own icons, so it should come as a standard item in LO!
Comment 4 QA Administrators 2015-12-20 16:11:13 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20