Bug 76684 - UI: Hyperlinks in Tables within Drawings and Presentations do not open as usual (click or ctrl+click)
Summary: UI: Hyperlinks in Tables within Drawings and Presentations do not open as usu...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Hyperlink
  Show dependency treegraph
 
Reported: 2014-03-27 12:50 UTC by Harald Koester
Modified: 2018-12-21 13:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2014-03-27 12:50:28 UTC
Problem description: 

Steps to reproduce:

[1] Open new drawing.
[2] Insert table.
[3] Click into a cell of the table.
[4] Insert Hyperlink into cell.
[5] Click outside the table.
[6] Move mouse pointer above hyperlink. Expected: Mouse pointer changes the appearance to “hand” and a tooltip is displayed: “Click to follow link ...” or “Crtl-Click to follow link ...”. But mouse pointer does not change the appearance, no tip is displayed and it is not possible to open the link.
[7] Click into cell with the hyperlink.
[8] Move mouse pointer above hyperlink: The appearance changes to “hand” and a tooltip with the url of the link is displayed, but it is not possible to open the link with a click or a Ctrl-click. 

In edit mode in Impress the behaviour is equal. During a slide show a click and also a Ctrl-Click opens the link.

Bug exists already in Version 3.5.0. Probably also earlier. 
              
Operating System: Windows 7
Version: 4.2.1.1 release
Comment 1 pierre-yves samyn 2014-03-27 13:06:03 UTC
Hello

You have to select the text of the Hyperlink, you can then either:
- with the mouse : right click > Open hyperlink
- with the keyboard : Shift+F10 to open context menu

So... WORKSFORME on windows with Version: 4.2.3.1
Build ID: 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13

Regards
Pierre-Yves
Comment 2 Harald Koester 2014-03-27 15:31:20 UTC
Hi Pierre-Yves,

you are right, it is possible to open the hyperlink. I did not know that way but I also did not expect it. So for me not very intuitive.

What I expect is a handling which is usual in most applikations and also in the LibreOffice components Writer and Calc. And the usual ways to open hyperlinks which I know are single click, double click or Ctrl-Click. So, to my opinion it is still a bug, but it is not really a severe problem.

Regards
Harald
Comment 3 pierre-yves samyn 2014-03-28 08:32:46 UTC
Hello

(In reply to comment #2)
> you are right, it is possible to open the hyperlink. 

This is why I wrote WORKSFORME (referring to the title of the Issue)

Nevertheless, I share your opinion, this feature is not very intuitive.
I wanted to set the status to "New" and I forgot... sorry

It's done now...
The report title should perhaps be changed?

Regards
Pierre-Yves
Comment 4 Joel Madero 2015-05-02 15:41:14 UTC Comment hidden (obsolete)
Comment 5 pierre-yves samyn 2015-05-09 10:51:53 UTC
Hi

Still reproduced on windows 7/64 & Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: fr_FR

I update the title according to comment 3

Previously "Other: Hyperlinks in Tables within Drawings and Presentations don't Work"

Regards
Pierre-Yves
Comment 6 QA Administrators 2016-09-20 09:41:45 UTC Comment hidden (obsolete)
Comment 7 Harald Koester 2016-09-28 11:31:56 UTC
Bug still exists in version 5.2.1 with Win7.
Bug already exists in version 3.3.0. Hence inherited from OOo.
Comment 8 QA Administrators 2018-08-22 02:38:14 UTC Comment hidden (obsolete)
Comment 9 Harald Koester 2018-09-05 08:40:45 UTC
Checked with version 6.1.0 (64 bit Win 10).

Behaviour at step 6 of initial report is now OK. The bug of step 8 still exists. During a slide show both click and Ctrl-click still open the hyperlink.

In bug 119703 I described this bug together with other issues. If that bug is confirmed, this bug can be marked as a duplicate.