Bug 76714 - EDITING: Multiple Language not supported?
Summary: EDITING: Multiple Language not supported?
Status: RESOLVED DUPLICATE of bug 75838
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-27 23:58 UTC by Raymond Willems
Modified: 2017-01-22 13:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The vocabulary file I want the second row to be checked in french (42.41 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-03-27 23:58 UTC, Raymond Willems
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raymond Willems 2014-03-27 23:58:18 UTC
Created attachment 96501 [details]
The vocabulary file I want the second row to be checked in french

Problem description: 

I made a spreadsheet with vocabulary.

First Row german words, second row french words.

When selecting the second row and editing the cells to "text", language french, the spell checker is not recognizing the new language.

Steps to reproduce:
1. Create new Spreadsheet
2. Write a word in the language of the document in A1
3. Write a word in a foreign language in B1
4. Select B1, edit cell text to "text" and select the used language
5. See that spell checker is still checking in the language set for the document

Current behavior:

Spell checker is not checking in used language

Expected behavior:

Spell checker should check spelling based on the setting in "Format cells - Numbers - Language"
Operating System: Mac OS X
Version: 4.1.5.3 release
Comment 1 Urmas 2014-03-28 00:09:24 UTC

*** This bug has been marked as a duplicate of bug 60062 ***
Comment 2 Raymond Willems 2014-03-28 00:37:35 UTC
Even saving and reopening doesn't solve my problem as in Bug 60062
Comment 3 Raymond Willems 2014-03-28 00:38:33 UTC
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of bug 60062 ***

Save-Reopen doesn't work for me. But thanks for the support already!
Comment 4 A (Andy) 2014-03-28 17:23:02 UTC
reproducible with LO 4.2.2.1 (Win 8.1)

Remark to step 4 (steps done): 
Go to FORMAT -> CELLS -> tab NUMBERS: CATEGORIES = select "Text" and LANGUAGE = select the other language
Comment 5 Raymond Willems 2014-03-28 17:27:43 UTC
(In reply to comment #4)
> reproducible with LO 4.2.2.1 (Win 8.1)
> 
> Remark to step 4 (steps done): 
> Go to FORMAT -> CELLS -> tab NUMBERS: CATEGORIES = select "Text" and
> LANGUAGE = select the other language

Thanks for trying!!

I did it exactly the same way, but it doesn't work with my version (4.1.5.3) on OS X.

Shall I try the unstable release 4.2.2.1 for OS X, 10.6.8?!?
Comment 6 A (Andy) 2014-03-29 07:37:30 UTC
@Raymond: 
Of course, you can change to LO 4.2 because it has many improvements, but because I checked it with 4.2.2.1 I suppose you will still have the bug.  But you also have to keep in mind, that the release 4.2.2.1 is called as a "Fresh" release which is the most feature rich version of the software, and is suited for early adopters willing to leverage a larger number of innovations.  For enterprise deployments, The Document Foundation suggests the more reliable LO 4.1.5 "Stable".  If you want a more stable version, then you should probably wait a little bit longer.
Comment 7 GRB 2014-10-23 13:08:09 UTC
I'm a native English speaker, but I can't get French spelling to work in Libreoffice.

Version: 4.2.6.3
Build ID: 420m0(Build:3)

Mint 17 Mate version
Comment 8 QA Administrators 2015-12-20 16:17:01 UTC Comment hidden (obsolete)
Comment 9 peter.kerling@gmx.de 2016-06-12 07:29:00 UTC
Problem still pending in 2016!
Comment 10 Tristan Miller 2017-01-22 13:41:44 UTC

*** This bug has been marked as a duplicate of bug 75838 ***