Download it now!
Bug 76747 - TABLE: Table of contents is expected not to refresh automatically
Summary: TABLE: Table of contents is expected not to refresh automatically
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-28 17:02 UTC by Jonathan Camilleri
Modified: 2015-01-24 14:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
attachment for debugging and illustration (289.49 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-03-28 17:02 UTC, Jonathan Camilleri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Camilleri 2014-03-28 17:02:41 UTC
Created attachment 96556 [details]
attachment for debugging and illustration

Problem description: 

Steps to reproduce:
Open the attachment and go to page 8.



Current behavior:
Upon opening the document the table of contents refreshes automatically.

Expected behavior:
Refreshing of the table of contents should be in a way that can be disabled.
Headings should not be maintained when a user has user a carriage return after typing a heading, as this behaviour is traditionally triggered in the minds of persons who are used to applications such as early versions of Office and Wordstar.
              
Operating System: Windows (other)
Version: 4.1.5.3 release
Comment 1 sophie 2014-04-10 15:48:54 UTC
Hi, your document is not structured to work correctly. An index is based upon heading styles and there are not organized in your document. For example, 1 Introduction and 1.1. Project problem have the same level of hierarchy: Heading 1, when 1.1 should use Heading2. Then 2.2.1 use Text Body style, etc...It seems also no hierarchy of styles are defined under Tools > Chapter Numbering. So please, read our documentation or come on the users list to get help on structuring your document, you will not meet any more problems index. Closing as not a bug - Sophie