Download it now!
Bug 76768 - Deleting of a Name for a cell causes LibreOffice to close and go into recovery mode for the document
Summary: Deleting of a Name for a cell causes LibreOffice to close and go into recover...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-29 03:24 UTC by PaulK
Modified: 2014-06-01 23:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PaulK 2014-03-29 03:24:41 UTC
I needed to delete a Name assigned to a cell.  I used the drop down menu Insert>Names>Mange and then, from within the "Manage Names" window I selected the name to be deleted.  I clicked on the "delete" button at which point the Manage Names window showed the name deleted. When I clicked on the "OK" button Libre closed and gave me the LibreOffice Document Recovery window.  When the document recovered, it recovered without the name being deleted.  Basically, I can't delete a name.
Comment 1 A (Andy) 2014-03-29 10:30:08 UTC
for me not reproducible with LO 4.2.2.1 (Win 8.1)

Is this only linked to a specific file or can you also reproduce this issue with a new file?
Comment 2 PaulK 2014-03-29 13:59:04 UTC
(In reply to comment #1)
> for me not reproducible with LO 4.2.2.1 (Win 8.1)
> 
> Is this only linked to a specific file or can you also reproduce this issue
> with a new file?

Thanks for quick response.

I created a new spreadsheet, created a name, and then deleted the name.  I also could not duplicate it.  I'll try a couple of things:

1. Create a new document with macro (the document having the problem has macros) and see if the problem is within the new document.

2. Do a "save as" with a different name and see if the problem will be in the new copied document.

3. Place the Problem Document onto a memory stick and open the document from another PC.

4. I'll open the Problem Doc from Ubuntu and see if the problem is there.

If you have additional suggestions for further isolating the problem, please pass them onto me.  

Again, thanks for your time and effort.  I'll update you on the outcome of the above.
Comment 3 A (Andy) 2014-03-29 15:03:44 UTC
@PaulK: Thanks for your very fast reply and your effort to try to reproduce it.  If you can reproduce it with your steps (very good suggestion), then please leave in a further comment how we can try to reproduce it.
Comment 4 PaulK 2014-04-01 16:56:01 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > for me not reproducible with LO 4.2.2.1 (Win 8.1)
> > 
> > Is this only linked to a specific file or can you also reproduce this issue
> > with a new file?
> 
> Thanks for quick response.
> 
> I created a new spreadsheet, created a name, and then deleted the name.  I
> also could not duplicate it.  I'll try a couple of things:
> 
> 1. Create a new document with macro (the document having the problem has
> macros) and see if the problem is within the new document.
> 
> 2. Do a "save as" with a different name and see if the problem will be in
> the new copied document.
> 
> 3. Place the Problem Document onto a memory stick and open the document from
> another PC.
> 
> 4. I'll open the Problem Doc from Ubuntu and see if the problem is there.
> 
> If you have additional suggestions for further isolating the problem, please
> pass them onto me.  
> 
> Again, thanks for your time and effort.  I'll update you on the outcome of
> the above.

Update with results and conclusion:

1. Created new document with macro - problem not present.

2. Did the "save as" on the problem document - problem carried over to the copy of the original problem document.

3. Placed problem document onto memory stick:

(a) Within Windows 7 the problem document no longer had the problem.
(b) Within another Windows XP PC the problem document had the problem.

4. Used the memory stick within Ubuntu - the problem document no longer had the problem.


Conclusion:  In its final days Windows XP somehow created the problem.  Since XP is history, this is not a problem.
Comment 5 m.a.riosv 2014-05-30 22:50:38 UTC
Please, can you try resetting the user profile in XP?
https://wiki.documentfoundation.org/UserProfile#Windows
Comment 6 PaulK 2014-06-01 23:12:34 UTC
(In reply to comment #5)
> Please, can you try resetting the user profile in XP?
> https://wiki.documentfoundation.org/UserProfile#Windows

I'm sorry, I no longer run XP on any of my PCs.
Comment 7 m.a.riosv 2014-06-01 23:37:15 UTC
Then we better close the bug. Please if you are not agree reopen it.