Download it now!
Bug 76772 - FORMATTING lost when "record changes" is active
Summary: FORMATTING lost when "record changes" is active
Status: RESOLVED DUPLICATE of bug 58813
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2014-03-29 12:04 UTC by slkleo
Modified: 2019-06-20 11:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Document showing the underisable behavior (32.68 KB, application/vnd.oasis.opendocument.text)
2014-03-29 12:04 UTC, slkleo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description slkleo 2014-03-29 12:04:30 UTC
Created attachment 96584 [details]
Document showing the underisable behavior

When editing a text with different formats, and recording the changes made (menu Edit->Changes->Record), if something is deleted near characters with another format, the deleted content loses its formatting. A few examples are shown in the attached file.

Steps to reproduce:
1. Create a new writer document;
2. Write a text with different font, color, etc.
3. Remove some of the text;
4. Save;
5. Both Undo and 'reject the change' are not able to restore the original formatting.

p.s.: it may be related to (or a duplicate of) this bug:
https://bugs.freedesktop.org/show_bug.cgi?id=58813
Comment 1 Yousuf Philips (jay) (retired) 2014-06-07 22:31:58 UTC
Confirmed in Linux Mint in 3.3.0, 4.2.4 and 4.3 beta.

Steps:
1. open blank document
2. type 'text text text text'
3. yellow highlight the second 'text'
4. turn on change recording (edit > changes > record)
5. delete the third 'text' and the space next to it right before the highlight
6. save the document
7. the yellow highlight spreads to the third 'text'
8. even pressing undo doesnt remove the yellow highlight for the third 'text'
Comment 2 QA Administrators 2015-12-20 16:10:53 UTC Comment hidden (obsolete)
Comment 3 slkleo 2015-12-25 13:02:37 UTC
This bug is still present in Libreoffice 5.1.0.1.
Comment 4 slkleo 2015-12-25 13:04:46 UTC
p.s.: tested in linux (lubuntu 15.10).
Comment 5 QA Administrators 2017-01-03 19:57:29 UTC Comment hidden (obsolete)
Comment 6 slkleo 2017-05-17 23:43:37 UTC
Still present in:

Version: 5.3.3.2
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448

and in

Version: 5.4.0.0.alpha1+
Build ID: b9d75dea30adaa53be58c112f255c9fcd3eea400

OS: Lubuntu 17.04, 64bits
Comment 7 QA Administrators 2018-05-19 02:35:23 UTC Comment hidden (obsolete)
Comment 8 slkleo 2018-05-22 20:14:46 UTC
This bug still present in Libreoffice Version: 6.0.4.2
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 9 QA Administrators 2019-05-23 02:50:03 UTC Comment hidden (obsolete)
Comment 10 Patrick Smits 2019-05-27 19:37:17 UTC
This bug is still present in Libreoffice 6.2.3.2 on Windows (reproduced via comment 1).
Comment 11 slkleo 2019-06-06 13:05:47 UTC
This bug is still present in Libreoffice Version: 6.3.0.0.beta1 on linux.

Strangely, the bug occurs when dealing with *.odt files.
When editing *.docx files, Libreoffice works fine.
Comment 12 László Németh 2019-06-20 11:22:18 UTC
Reject supports clear formatting now, see Bug 52391.
Comment 13 László Németh 2019-06-20 11:25:11 UTC

*** This bug has been marked as a duplicate of bug 58813 ***