Bug Hunting Session
Bug 76784 - FILEOPEN: Sheet References Lost
Summary: FILEOPEN: Sheet References Lost
Status: RESOLVED DUPLICATE of bug 75950
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-29 20:16 UTC by C A J
Modified: 2015-01-24 14:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example Problem File (555.79 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-03-29 20:16 UTC, C A J
Details
Example Screenshot (190.78 KB, image/png)
2014-03-29 20:17 UTC, C A J
Details
Example Printed Pages (50.31 KB, application/html)
2014-03-29 20:18 UTC, C A J
Details

Note You need to log in before you can comment on or make changes to this bug.
Description C A J 2014-03-29 20:16:53 UTC
Created attachment 96600 [details]
Example Problem File

(Note: the actual LO version I'm using is 4.2.2-2, installed on Arch Linux/xfce with pacman -Syu 3/19/2014. Also note that this may be similar to Bugs #75846 and 75950, though in a later minor version and on a different OS.)

I briefly mentioned this problem in Bug #76411. The primary focus of that report was recalculation which I resolved through the guidance of Eike Rathke and m.a.riosv. Thank you both.

I opened this ticket because of that companion problem that I thought would go away with the recalculation resolution, but it didn't. Here are the details:

The attached spreadsheet file, which I have been using for quite a long time, has four sheets. The first sheet is named Overview. Cells A1 and A3 of the other three sheets refer back to Overview for titling information as follows:

	A1: =Overview.A1
	A3: =Overview.A3

Additionally, the Recap sheet summarizes data from Journal with broad use of a formula of the form:

	C6: =SUMIF(Journal.$G$5:$G$13681,C$4&$B6,Journal.$E$5:$E$13681)

Since my 3/19/2014 upgrade to LO 4.2.2-2, Calc has had 'trouble remembering' the sheet references between saving, closing, and reopening the file. On reopening at various times I have seen:

	A1: =A1
	A3: =#REF!!.A3
	C6: =SUMIF(#REF!!$G$5:$G$13681,C$4&$B6,#REF!!$E$5:$E$13681)
	C6: =SUMIF( $G$5:$G$13681,C$4&$B6, $E$5:$E$13681)

I was no help in detailing this problem in the earlier report, due to my reluctance to share the financial data in the file. I have, however, modified the file to remove all personal references, while preserving the structure, size, and data relationships of the various cells. This copy of the file behaves in the same incorrect manner as my original: If I correct the two types of sheet references, it's fine during the Calc session, including after saving. If I save the file, close it, and reopen it, it reverts back to the missing-sheet-reference condition.

In addition to the redacted spreadsheet file, I will also upload a screenshot (.png) and a print image (.pdf) of the Recap sheet. These will give a picture of what the sheet looks like when working correctly.

Many thanks for your guidance on this issue. I am happy to provide any other information that may help.
Comment 1 C A J 2014-03-29 20:17:26 UTC
Created attachment 96601 [details]
Example Screenshot
Comment 2 C A J 2014-03-29 20:18:08 UTC
Created attachment 96602 [details]
Example Printed Pages
Comment 3 m.a.riosv 2014-03-31 00:00:44 UTC
Hi C A J, thanks for the patient.

I have verified that it is reproducible saving as XLS with
Win7x64Ultimate.
Version: 4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f

But it is solved in:
Versión: 4.2.3.2 Id. de compilación: 7c5c769e412afd32da4d946d2cb0c8b0674e95e0

you can find this pre-release:
http://downloadarchive.documentfoundation.org/libreoffice/old/4.2.3.2/

In any case it is a duplicate.

*** This bug has been marked as a duplicate of bug 75950 ***
Comment 4 C A J 2014-03-31 02:28:14 UTC
Many, MANY thanks for your investigation of this problem. While I appreciate the offer of the pre-release version, I will wait until it comes through the official Arch Linux pacman channels. Just knowing it's repaired is enough for now.

Again, thanks.