Bug Hunting Session
Bug 76834 - [FORMATTING] RTL text rendered incorrectly when presenting on Windows
Summary: [FORMATTING] RTL text rendered incorrectly when presenting on Windows
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL Slide-Show
  Show dependency treegraph
 
Reported: 2014-03-31 13:07 UTC by Shimi Chen
Modified: 2017-03-08 09:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example odp of the bug (18.23 KB, application/vnd.oasis.opendocument.presentation)
2014-03-31 13:07 UTC, Shimi Chen
Details
example odp of the bug with arabic instead of hebrew (18.83 KB, application/vnd.oasis.opendocument.presentation)
2014-03-31 14:16 UTC, Shimi Chen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shimi Chen 2014-03-31 13:07:44 UTC
Created attachment 96654 [details]
example odp of the bug

When using Impress to present an odp file containing RTL text on Windows, It is at best displayed in LTR directionality and at worst completely messed up.

I tested on Linux and Windows (both with LO 4.2.2.1). The bug only shows up on Windows. On Linux everything is rendered correctly as far as I could tell (which is misleading when making and testing a presentation on Linux to present on a Windows box).

Attached is a simple example file of the bug.

Note that it does not matter on which platform the presentation is made, it will display incorrectly on Windows, and only in full-screen presentation mode.

Screenshots:

Windows edit mode (ok) - http://imgur.com/80THCNM
Linux edit mode (ok) - http://imgur.com/rFXKnjA
Windows present mode (bad) - http://imgur.com/kBfT7NN
Linux present mode (ok) - http://imgur.com/wwogfMx
Comment 1 Shimi Chen 2014-03-31 14:16:43 UTC
Created attachment 96661 [details]
example odp of the bug with arabic instead of hebrew
Comment 2 Yousuf Philips (jay) (retired) 2014-09-30 05:24:20 UTC
Hello Shimi,

Thank you for reporting the bug. I can confirm that in slide show mode the arabic is not shown correctly in 4.3.3.

Version: 4.3.3.0.0+
Build ID: bb21fe6d0a59df7f2c639c60e5e2aca0db9111ce
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-09-23_23:29:45
Comment 3 QA Administrators 2016-09-20 10:18:42 UTC Comment hidden (obsolete)
Comment 4 Shimi Chen 2016-10-31 09:36:03 UTC
Still occurs in 5.2.2.2.0 (Windows 8 x64).
Comment 5 Shimi Chen 2017-03-08 09:30:55 UTC
Seems like this bug is fixed with the new renderer in 5.3.