Bug 76835 - libvisio: Elemets are not transparency
Summary: libvisio: Elemets are not transparency
Status: RESOLVED FIXED
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: libvisio (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-31 13:11 UTC by Dennis Roczek
Modified: 2017-10-30 11:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
missing transparency results in "loose of information" (1.10 MB, application/visio.drawing)
2014-03-31 13:11 UTC, Dennis Roczek
Details
Image 1: LibreOffice Draw with moved element to see "hidden" content (54.98 KB, image/png)
2014-03-31 13:12 UTC, Dennis Roczek
Details
Image 2 and 3: Microsoft Visio Viewer showing the VSD correctly (136.37 KB, image/png)
2014-03-31 13:14 UTC, Dennis Roczek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Roczek 2014-03-31 13:11:14 UTC
Created attachment 96655 [details]
missing transparency results in "loose of information"

The attached Visio file (vsd) was downloaded from Microsoft including ~20 example Visio files. ( http://www.microsoft.com/en-us/download/details.aspx?id=24023 )

This file is a construction plan, but not all elements are visible as the "room qm layers" above all rooms hide the underlying elements. (see Image 1)

Additional is the "green striped background" not rendered(?) (see Image 2). I didn't found any layer containing the color, but I might have missed it. At least it is not displayed as it should be intended!

The Microsoft's Visio Viewer displays it correctly (see Image 3 upload in a few minutes).
Comment 1 Dennis Roczek 2014-03-31 13:12:30 UTC
Created attachment 96656 [details]
Image 1: LibreOffice Draw with moved element to see "hidden" content
Comment 2 Dennis Roczek 2014-03-31 13:14:21 UTC
Created attachment 96657 [details]
Image 2 and 3: Microsoft Visio Viewer showing the VSD correctly
Comment 3 thackert 2014-04-27 15:04:39 UTC
Hello Dennis, *, 
I can confirm your bug with LO Version: 4.1.5.3 Build-ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24 with installed Germanophone lang- as well as helppack under Debian Testing i686, so I will change the version adequately ... ;) Further investigation reveals, that LO Version: 4.2.3.3 Build-ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff0, Version: 4.2.4.1 Build ID: d4c441391e20647b3d2e8dde4d20aa868e77e515 and Version: 4.3.0.0.alpha1 Build-ID: 46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781 (all three parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel and with Germanophone lang- as well as helppack) shows the same bug ... :(
HTH
Thomas.
Comment 4 Fridrich Strba 2015-12-14 00:44:11 UTC
The green-ish fill is actually a hatching fill which we don't support yet. Nevertheless, I modified libvisio, so that we actually account for transparency when we replace this hatching with a solid fill with the background colour.
It is this commit in libvisio:
http://cgit.freedesktop.org/libreoffice/libvisio/commit/?id=0ef93c0af5304b7876813a6fcff7cdaabc380cee

It will take some time before this is released and before the change gets into LibreOffice, but technically it is now fixed and I am marking it as such