Download it now!
Bug 76888 - EDITING -Forms Design Mode selected but does not allow Design of Field Properties
Summary: EDITING -Forms Design Mode selected but does not allow Design of Field Proper...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.7.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 76889 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-01 08:17 UTC by Jacqueline.tarleton
Modified: 2015-10-12 23:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
picture of screen when design mode button is depressed (275.54 KB, image/png)
2014-04-01 08:17 UTC, Jacqueline.tarleton
Details
"open in design" button doesn't toggle on/off design mode. (293.87 KB, image/jpeg)
2015-05-30 15:20 UTC, ELSUPREMO1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jacqueline.tarleton 2014-04-01 08:17:16 UTC
Created attachment 96700 [details]
picture of screen when design mode button is depressed

In LibreOffice Database: Database Form
In Field Label (column name) section, the property for the field appeared to be a list but no list was shown. When attempted to use the Open In Design Mode button to edit the form, the button could be selected but no other options became available. Column Label has limited options. Tried reinstalling Java Runtime Environment and Libre Office.

Cannot edit the property of the column to add a list of options to the listbox.

Cannot save the new records because the property for the Column is that a selection from a list must be made.

Cannot create data for the database because without a listbox, the software will not allow the form to be saved. 

When the Open in Design Mode is selected, the button is depressed but no other icons show they are active. The picture shows what I see when the design mode is selected.
Comment 1 Robert Großkopf 2014-04-01 18:13:26 UTC
In the screenshot I see a button pressed for open the document in Design-View, not in for Input any values in the form. This button is doing nothing when you have opened the form already or opened a form in a *.odb-file. If you will open a form for editing, which is created in a database, you have mark the form with a right-mouse-click and chose "Edit" in the contextmenue or Edit → Edit in the mainmenue of Base.

If you have created an external form it should work, when you press the button "Open Document in Design-View", save the document and reopen it.

I will close Bug76889, because it's a duplicate of this one.
Comment 2 Robert Großkopf 2014-04-01 18:13:51 UTC
*** Bug 76889 has been marked as a duplicate of this bug. ***
Comment 3 Robert Großkopf 2014-10-19 16:02:30 UTC
Anything new with this report?

The bug couldn't be confirmed, no answer is given for the comments ...
Comment 4 Alex Thurgood 2015-01-03 17:39:33 UTC
Adding self to CC if not already on
Comment 5 ELSUPREMO1 2015-05-30 15:20:58 UTC
Created attachment 116177 [details]
"open in design" button doesn't toggle on/off design mode.

Hi,

The "open in design" button doesn't toggle on/off design mode. That's the bug. The work around which is a poor method is having to edit a form before the form loads. After, the form is laoded you still you cannot turn design mode properties on/off.

I should be able to open the form in normal view mode and then click the "open in design" button to activate/deactivate design mode to make design edits (see attached picture).
Comment 6 Julien Nabet 2015-10-11 14:24:07 UTC
"Assigned" field is "The person in charge of resolving the bug" (see https://bugs.documentfoundation.org/page.cgi?id=fields.html#assigned_to)
Comment 7 Julien Nabet 2015-10-11 14:28:18 UTC
On LO Debian x86-64 with LO Debian package 5.0.2, "Design mode" button is disabled when just opening form (not in edit mode).
In edit mode, toggling "Design mode" button works.
Let's put this one to WFM.

If I'm wrong or missed something and reproduce the problem with recent LO version, don't hesitate to reopen this tracker.