Download it now!
Bug 76924 - FILESAVE: Saving as Excel 2003 XML fails
Summary: FILESAVE: Saving as Excel 2003 XML fails
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-01 20:54 UTC by web
Modified: 2016-02-27 11:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
File which fails to save again. (10.63 KB, text/xml)
2014-04-01 20:54 UTC, web
Details

Note You need to log in before you can comment on or make changes to this bug.
Description web 2014-04-01 20:54:26 UTC
Created attachment 96750 [details]
File which fails to save again.

An existing file in the Excel 2003 XML format is loaded.
Now somehting is changed, at least one character, it isn't possible to save it again.

An error dialog appears:
"Fehler beim Speichern des Dokumentes project: Schreibproblem. Die Datei konnte nicht geschrieben werden."

Translation:
"Error during saving the document project: Write problem. The file couldn't be saved."

The original file was created with LibreOffice Calc too.
Comment 1 Tomaz Vajngerl 2014-04-01 21:39:50 UTC
Confirmed. 

Still, is there a reason you are using Excel 2003 XML format instead of ods, xls, xlsx?
Comment 2 Urmas 2014-04-02 01:19:45 UTC
Excel 2003 XML is de facto standard of information interchange.
Comment 3 Eike Rathke 2014-04-02 13:42:25 UTC
Not true, Excel 2003 .xml was an interim format, the actually widespread format is Excel 2007 .xlsx
Comment 4 web 2014-04-02 16:08:43 UTC
(In reply to comment #1)
> Confirmed. 
> 
> Still, is there a reason you are using Excel 2003 XML format instead of ods,
> xls, xlsx?

Yes, because I use this format for XML transformation via XSLT. And this is the only plain xml format, which can be read/write from LibreOffice and Excel.
Comment 5 QA Administrators 2016-02-21 08:34:34 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice 
   (5.0.5 or 5.1.0)  https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and 
   your operating system, and any changes you see in the bug behavior
 
   If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
   a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
   appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-02-21
Comment 6 web 2016-02-27 11:24:17 UTC
The problem is fixed in v5.1.0.3.