Bug 77021 - FILESAVE: Print range not saved when spreadsheet is linked with another spreadsheet on at least 1 tab
Summary: FILESAVE: Print range not saved when spreadsheet is linked with another sprea...
Status: VERIFIED DUPLICATE of bug 51022
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Attila Szűcs
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Print-Range
  Show dependency treegraph
 
Reported: 2014-04-03 17:58 UTC by sviatoslav
Modified: 2021-02-08 11:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Zip file containing 2 sample documents on which the issue is demonstrated (144.25 KB, application/zip)
2014-04-03 17:58 UTC, sviatoslav
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sviatoslav 2014-04-03 17:58:37 UTC
Created attachment 96865 [details]
Zip file containing 2 sample documents on which the issue is demonstrated

Problem description: 
Print range defined in 1 tab is not saved of file save.

Steps to reproduce:
1. Download attached zip file and extract the 2 files into the same folder.

2. Open FS.ods

3. Say "Yes" to update links (there should not be any errors)

4. Go to tab "IS"

5. Select range A1:D33

6. Click Format >> Print Ranges >> Define

7. Save the file and exit the application

8. Re-open FS.ods and go to tab "IS"

9. Click File >> Page Preview

Current behavior:
The preview page shows nothing because the ranges was not saved (or so it appears). Also, actually printing this tab does not print anything (nothing is sent to printer). Tab "BS" however, seemed to have worked when I first tried it, so this is only visible on tab "IS". Breaking the link and then defining the range and saving works perfectly, so it must be related to the sheet being linked to another sheet.

Expected behavior:
The defined range in step 6 above should have been saved and when the file re-opened, it should have been defined and page preview should show the content of the range.
              
Operating System: Windows 7
Version: 4.2.2.1 release
Comment 1 Dominique Boutry 2014-04-08 09:28:36 UTC
Reproduced on new Calc documents (same LibO version and OS).
Comment 2 HT 2015-01-13 01:18:51 UTC
Most likely this is a duplicate of bug 51022.
It's been more than 2 years since the bug was reported, but no action taken thus far.

Only the last sheet is affected.
As a work-around, you can insert a blank sheet to the end.
Comment 3 QA Administrators 2016-01-17 20:02:52 UTC Comment hidden (obsolete)
Comment 4 sviatoslav 2016-03-01 23:46:18 UTC
This bug is still reproducible on LibreOffice Calc 5.1.0.3 (release)
Comment 5 QA Administrators 2017-03-06 15:17:30 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2020-02-04 03:31:05 UTC Comment hidden (obsolete)
Comment 7 Attila Szűcs 2021-01-28 07:51:42 UTC

*** This bug has been marked as a duplicate of bug 51022 ***
Comment 8 NISZ LibreOffice Team 2021-02-08 11:38:32 UTC
Verified in
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 44b914b1e2616ca8f70e896e653a46ca93610234
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded