Bug 77022 - LO should not save to profile default color and gradients if not modified
Summary: LO should not save to profile default color and gradients if not modified
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Area-Fill-Tab Color-Palettes User-Profile
  Show dependency treegraph
 
Reported: 2014-04-03 18:23 UTC by Arnaud Versini
Modified: 2019-05-11 11:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Old colors (16.22 KB, image/png)
2014-04-03 18:23 UTC, Arnaud Versini
Details
New colors (16.11 KB, image/png)
2014-04-03 18:36 UTC, Arnaud Versini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arnaud Versini 2014-04-03 18:23:29 UTC
Created attachment 96866 [details]
Old colors

Steps to reproduce :
- Install an old LibreOffice like 3.6
- Launch LibreOffice and go to colors options, change nothing
- Launch LibreOffice 4.1 or 4.2
- See colors by using any formating option like paragraph background

Expected behavior :
- A good looking palete like one in attachment

Results :
- A mess of colors like in attachment, old colors
Comment 1 Arnaud Versini 2014-04-03 18:36:51 UTC
Created attachment 96868 [details]
New colors
Comment 2 Jorendc 2014-04-04 20:59:59 UTC
As far I can see, not reproducible tested using Mac OSX 10.9 with LibreOffice 3.6.7 and 4.1.5

Kind regards,
Joren
Comment 3 Arnaud Versini 2014-04-05 09:45:26 UTC
@joren , just tested between 4.0 and 4.1 the problem is there. Sorry about mentionning 3.6. Could you test again ?
Comment 4 William Gathoye 2014-04-09 15:01:17 UTC
Tested on 4.2.2 (ArchLinux), and I can confirm, the colors are in a mess.
Comment 5 William Gathoye 2014-04-10 10:15:52 UTC
I made some deeper tests, this time on an outdated GNU/Linux distribution: Elementary OS (based on Ubuntu 12.04 LTS).

I installed successively LibO 3.5, 3.6, 4.0 and 4.2.

All versions before 4.2 have disorganized colors. When we upgrade to 4.2, these colors are still disorganized. But if we remove the libreoffice profile located at ~/.config/libreoffice, the colors became well organized.
Comment 6 QA Administrators 2015-06-08 14:42:15 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2016-09-20 10:01:14 UTC Comment hidden (obsolete)
Comment 8 Cor Nouws 2019-05-11 11:11:52 UTC
Hi Arnaud,

Since palettes and behavior have changed a lot, I think this can be closed as resolved. 
Cor