Bug 77042 - RTF: wrong formatting tables in the rtf file
Summary: RTF: wrong formatting tables in the rtf file
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: Other All
: medium major
Assignee: Not Assigned
Whiteboard: BSA
Keywords: filter:rtf
Depends on:
Blocks: RTF-Tables
  Show dependency treegraph
Reported: 2014-04-04 07:41 UTC by ttro2002
Modified: 2017-10-05 22:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

Attachment contents 7 files : source rtf-file and 6 screenshots (245.70 KB, application/zip)
2014-04-04 07:41 UTC, ttro2002
screenshot in pdf format (290.39 KB, application/pdf)
2014-04-07 05:59 UTC, ttro2002
source file (343.97 KB, text/rtf)
2014-04-07 06:00 UTC, ttro2002

Note You need to log in before you can comment on or make changes to this bug.
Description ttro2002 2014-04-04 07:41:47 UTC
Created attachment 96886 [details]
Attachment contents 7 files : source rtf-file and 6 screenshots

Problem description: 
Every month we recive rtf-file via e-mail.
When I am opening file in libre writer, table inside it have been corrupted. 
Ordinary corrupted first(or second) and last pages, but this time almost all table corrupted.
I don`t see content of the table. 
The number and width of columns are wrong. 
I try to use libre writer version from 3.5 to
in windows XP(32bit),vista(32bit),7(64bit), ubuntu 12.04(64bit).
In open office 3.2.1(attached file fileOOO1.png and fileOOO2.png) and MS word 2003-2010(fileWORD2003.png WORD2010.png) file opened normally.

Steps to reproduce:
1. Open file(attached file file1.rtf)
2. look at the table. It looks like on attached file(libre1.png and libre2.png)

Current behavior:
Content of the table in the file is corrupted.

Expected behavior:
The table should look fine.

Operating System: Windows XP
Version: release
Comment 1 ttro2002 2014-04-07 05:59:17 UTC
Created attachment 97010 [details]
screenshot in pdf format
Comment 2 ttro2002 2014-04-07 06:00:01 UTC
Created attachment 97011 [details]
source file
Comment 3 Jorendc 2014-04-07 21:05:16 UTC
Thanks for reporting.

In one of the screenshots in the ZIP file I also see you have almost the same incorrect behaviour using LibreOffice -> marking as such (version = oldest reproducible version of libreoffice)

I can reproduce this incorrect behavior, tested using Linux Mint 16 x64 with LibreOffice Version:
Build ID: d06cc9b52d3023f7b5aacb50bd48b06b9ffefbd3

Kind regards,
Comment 4 ttro2002 2014-05-25 18:29:20 UTC
Today I try to install Libre 4.3.0 beta1 . Table looks fine. Can I mark the problem as solved?
Comment 5 Jorendc 2014-05-25 19:28:48 UTC
(In reply to comment #4)
> Today I try to install Libre 4.3.0 beta1 . Table looks fine. Can I mark the
> problem as solved?

Doesn't look resolved to me, tested using 4.3.0 beta 1. Table is still mangled. Can you please attach a screenshot how it looks in 4.3b1 for you?

Kind regards,
Comment 6 ttro2002 2014-05-26 19:22:19 UTC
Sorry. It was another file with same table.
Comment 7 Alexandr 2014-08-08 05:34:14 UTC
Reproducible with LibreOffice 4.2.5 and on Debian.
Comment 8 QA Administrators 2015-09-04 02:49:26 UTC Comment hidden (obsolete)
Comment 9 ttro2002 2015-09-10 17:34:51 UTC
Hi everyone who try to help. Today I try to open source file with LO (windows 7 x64). It`s looks correctly.
Comment 10 Robinson Tryon (qubit) 2015-12-17 05:52:32 UTC Comment hidden (obsolete)