Download it now!
Bug 77077 - FILEOPEN: Apparent 'freeze' opening SVG files converted by ImageMagick
Summary: FILEOPEN: Apparent 'freeze' opening SVG files converted by ImageMagick
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-05 07:11 UTC by John Smith
Modified: 2016-05-26 12:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
'sample1' small SVG converted by ImageMagick (22.73 KB, application/x-zip-compressed)
2014-04-05 07:11 UTC, John Smith
Details
'sample2' large SVG converted by ImageMagick (2.42 MB, application/x-zip-compressed)
2014-04-05 07:12 UTC, John Smith
Details
callgrind results: opening and closing 'sample1' (4.57 MB, application/x-bzip)
2015-02-07 08:04 UTC, Maarten Hoes
Details
callgrind results: opening 'sample2' (terminated after 20 minutes) (1.98 MB, application/x-bzip)
2015-02-07 08:06 UTC, Maarten Hoes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Smith 2014-04-05 07:11:28 UTC
Created attachment 96932 [details]
'sample1' small SVG converted by ImageMagick

When you convert files to SVG format using ImageMagick, the file is converted to a rasterized image where each pixel is saved as a 'circle' that is 1x1. The converted file will have lots of lines like this: ' <circle cx="0" cy="0" r="1" fill="white"/> '

LibreOffice has problems opening such SVG files. When the file is relatively small, like attachment sample1.svg, LibreOffice takes about 30 seconds (on my system) to open the file. It appears to hang, but recovers. When the file is relatively large, like attachment sample2.svg, LibreOffice simply hangs/freezes (Not Responding).
Comment 1 John Smith 2014-04-05 07:12:18 UTC
Created attachment 96933 [details]
'sample2' large SVG converted by ImageMagick
Comment 2 tommy27 2014-06-17 18:34:44 UTC
tested under Win7x64 using LibO 4.2.4.2
I confirm opening sample1 file is quite slow in LibO

status NEW
Comment 3 Rostislav 'R.Yu.' Okulov 2015-02-05 16:33:18 UTC
No problem with sample1.svg it opened with ~3-5 sec in LO 4.1 and 4.3

sample2.svg not tested because it is very large.
Comment 4 Maarten Hoes 2015-02-06 14:54:08 UTC
I can reproduce the issue on my 32GB RAM Intel Core i7-4771 CPU @ 3.50GHz system with Windows 8.1. With both LibreOffice versions 4.3.5.2 and master (4.5.0.0.alpha0+ Build ID: 1845b6af3991ca5521eef48aafe1d0489e2ff8f6) : opening sample1.svg takes about 15 seconds, and sample2.svg is still not opened after 60 seconds (I closed the application at that point).
Comment 5 Maarten Hoes 2015-02-07 08:04:49 UTC
Created attachment 113196 [details]
callgrind results: opening and closing 'sample1'

LibreOffice ~master commit f1359d1221b335c4856821948f89868f021135eb Date: Fri Feb 6 18:24:46 2015 +0100 on Fedora 21: opening and clising 'sample1.svg' callgrind results.
Comment 6 Maarten Hoes 2015-02-07 08:06:26 UTC
Created attachment 113197 [details]
callgrind results: opening 'sample2' (terminated after 20 minutes)

LibreOffice ~master commit f1359d1221b335c4856821948f89868f021135eb Date: Fri Feb 6 18:24:46 2015 +0100 on Fedora 21: opening 'sample2.svg' callgrind results (terminated after 20 minutes).
Comment 7 Maarten Hoes 2015-02-07 09:31:09 UTC
Reproduced with LibreOffice 3.3.1.2
Comment 8 QA Administrators 2016-02-21 08:34:48 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice 
   (5.0.5 or 5.1.0)  https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and 
   your operating system, and any changes you see in the bug behavior
 
   If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
   a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
   appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-02-21
Comment 9 John Smith 2016-02-21 09:57:01 UTC
reproduced with LibreOffice: Version: 5.1.0.3 Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
on Windows 10 version 1511 build 10586.104

opening sample1.svg takes about ~27 seconds
opening sample2.svg was still not opened after about ~60 seconds at which point i closed the application.
Comment 10 JoNi 2016-05-24 17:27:02 UTC
Think this is a WONTFIX

I doubt such files are used anywhere and I don't see how we could fix this.
One can import them in any LO document in reasonable time (considering the humongous file sizes and pixel representation).

For editing in draw every circle element gets a node object.
For the first file that's 79*119 nodes. (It's Over 9000!!!)
The second file has 757.350 circles/pixels. I doubt there is any editor out there who can handle this. These files are clearly not made for editing in svg format.
Comment 11 John Smith 2016-05-26 12:12:27 UTC
(In reply to JoNi from comment #10)
> Think this is a WONTFIX
> 
> I doubt such files are used anywhere and I don't see how we could fix this.
> One can import them in any LO document in reasonable time (considering the
> humongous file sizes and pixel representation).
> 
> For editing in draw every circle element gets a node object.
> For the first file that's 79*119 nodes. (It's Over 9000!!!)
> The second file has 757.350 circles/pixels. I doubt there is any editor out
> there who can handle this. These files are clearly not made for editing in
> svg format.

Hi,

I tried opening both files with ImageMagick 7.0.1 on Windows Home 10 (build 10587.318).

'sample1.svg' opens in about 1 second. 'sample2.svg' opens in roughly 15 seconds. Both open fine without issues and/or 'hangs/freezes'.