Bug 77128 - LibreOffice fails to start on KDE4
Summary: LibreOffice fails to start on KDE4
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.2.3.2 rc
Hardware: Other All
: medium normal
Assignee: Jan-Marek Glogowski
QA Contact:
URL:
Whiteboard:
Keywords: regression
: 77303 77400 77446 77463 78595 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-07 09:47 UTC by Björn Michaelsen
Modified: 2014-05-12 11:45 UTC (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2014-04-07 09:47:31 UTC
From downstream bug lp#1300283:
It seems that the latest RC of LO is completely broken on KDE 4.

Launching the LO center causes nothing to come up ( I can see a window title, but nothing inside the window itself ), launching writer causes a window to come up, which immediately hangs.

Multiple users have brought this up on the Kubuntu Devel mailing list too.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Mar 31 17:22:08 2014
InstallationDate: Installed on 2014-03-18 (12 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140318)
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

This comment https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1300283/comments/10 reports that copying the KDE plugin from 4.2.1 in solves this.


There are commits in vcl/unx/kde4 about fdo#73115, fdo#45935 and fdo#74416 -- one of them is likely causing this regression.
Comment 1 Rene Engelhard 2014-04-07 09:58:47 UTC
copying the file from 4.2.1(!) (as your commment) fixes the bug in 4.1.2(!) (as Version) says?!

either one is incorrect I assume...
Comment 2 Rene Engelhard 2014-04-07 10:08:16 UTC
... or it is fixed in 4.2.x and needs to be backported to 4.1.x (but 4.1.x without jmux' branch is broken per se)
Comment 3 Björn Michaelsen 2014-04-07 10:10:34 UTC
nope, fumbled when setting the version -- this is a recent regression on the 4.2 branch.
Comment 4 Maxim Monastirsky 2014-04-07 10:54:15 UTC
It's http://cgit.freedesktop.org/libreoffice/core/commit/?id=7dba6e0a71d090f06a6a1a39e87572674593b48a&h=libreoffice-4-2. See Bug 73115 comment 9. It was solved by later commits, which unfortunately didn't go to 4.2.3.
Comment 5 Björn Michaelsen 2014-04-07 12:38:01 UTC
(In reply to comment #4)
> It's
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=7dba6e0a71d090f06a6a1a39e87572674593b48a&h=libreoffice-4-2. See Bug
> 73115 comment 9. It was solved by later commits, which unfortunately didn't
> go to 4.2.3.

Confirmed, reverting 7dba6e0a71d090f06a6a1a39e87572674593b48a makes 4.2.3~rc3 starts at least on kde.

@Jan-Marek: Any plans to backport the fixes for 4.2.4 (or are they already?)
Comment 6 Maxim Monastirsky 2014-04-07 12:41:58 UTC
@Björn: See http://lists.freedesktop.org/archives/libreoffice/2014-March/060260.html. Those fixes are already in libreoffice-4-2 branch.
Comment 7 Björn Michaelsen 2014-04-07 12:55:11 UTC
Ok, marking as resolved/fixed then and assigning to Jan-Marek as he did the work on this one. 

LibreOffice users on KDE4 are thus encouraged to test the 4-2 nightlies from:
 http://dev-builds.libreoffice.org/daily/libreoffice-4-2/
to see if there are remaining issues on the upcoming 4.2.4.
Comment 8 Maxim Monastirsky 2014-04-16 07:49:19 UTC
*** Bug 77446 has been marked as a duplicate of this bug. ***
Comment 9 Maxim Monastirsky 2014-04-16 07:51:14 UTC
*** Bug 77303 has been marked as a duplicate of this bug. ***
Comment 10 Maxim Monastirsky 2014-04-16 12:54:46 UTC
*** Bug 77400 has been marked as a duplicate of this bug. ***
Comment 11 Maxim Monastirsky 2014-04-16 19:37:25 UTC
*** Bug 77463 has been marked as a duplicate of this bug. ***
Comment 12 Maxim Monastirsky 2014-04-17 15:30:19 UTC
@Björn: Turns out that it was actually fixed by Luboš Luňák with http://cgit.freedesktop.org/libreoffice/core/commit/?id=71f2aff7a56cef4e133abad3c2e447c76c5ee1fe. Unfortunately it's not in 4.2 yet, so I submitted a request to gerrit:

https://gerrit.libreoffice.org/9079/

Of course I verified that it fixes the bug for 4.2.
Comment 13 Maxim Monastirsky 2014-05-12 11:45:25 UTC
*** Bug 78595 has been marked as a duplicate of this bug. ***