Bug 77242 - Writer/Web: segfault from Format>Page
Summary: Writer/Web: segfault from Format>Page
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Andras Timar
URL:
Whiteboard: target:4.2.5
Keywords: bibisected, regression
: 78528 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-09 13:32 UTC by Uwe Wiest
Modified: 2015-12-17 07:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Wiest 2014-04-09 13:32:35 UTC
Writer Web stürzt ab beim Versuch, das Menü "Seite" aufzurufen. Gespeicherte Datei lässt sich nicht wieder aufrufen.
Damit ist libreoffice als Web-Editor unbrauchbar geworden.
Comment 1 Jorendc 2014-04-18 21:22:53 UTC
Please communicate in English. Provide step by step how to reproduce your problem. If possible, attach a sample document too.

Thanks for your extra information.

Kind regards?
Joren
Comment 2 Uwe Wiest 2014-04-23 09:11:45 UTC
 1. Open an empty  writer/web document. Choose Kontext-Menu "Page"
    (German: Seite). Libreoffice crashes. So it is for example
    impossible to create a background
 2. Open a Writer/Web document. Write a Text, create a spreadsheet. Save
    the document. It becomes very large.
    You cannot open it with Libre again or only with strange changes.

This happens with Libreoffice in ubuntu-linux, in window 7 and windows 
8.1. Version 4.2.3
Libreoffice Version 4.1.5 writer/web is o.k.

Kind regards
Dr. Uwe Wiest




Am 18.04.2014 23:22, schrieb bugzilla-daemon@freedesktop.org:

> Jorendc <mailto:jorendc@libreoffice.org> changed bug 77242 
> <https://bugs.freedesktop.org/show_bug.cgi?id=77242>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEEDINFO
> CC 		jorendc@libreoffice.org
> Ever confirmed 		1
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=77242#c1> 
> on bug 77242 <https://bugs.freedesktop.org/show_bug.cgi?id=77242> from 
> Jorendc <mailto:jorendc@libreoffice.org> *
> Please communicate in English. Provide step by step how to reproduce your
> problem. If possible, attach a sample document too.
>
> Thanks for your extra information.
>
> Kind regards?
> Joren
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 3 Harald Koester 2014-04-23 21:55:43 UTC
Writer/Web also crashes, if you try to format a page via the menu:

1. Create new HTML Document: File > New > HTML Document
2. Format > Page...: Writer crashes, expected: No crash
Comment 4 k-j 2014-04-24 08:25:15 UTC
Can confirm it in WIN XP 32bit with LibO 4.2.4 RC1 and WIN 8.1 Upd 1 with LibO 4.2.3.3 portable
Comment 5 Terrence Enger 2014-04-24 15:08:06 UTC
Working on debian-wheezy, I see varying results:

(*) LibreOffice version 3.5.4.2, delivered with debian-wheezy, has no
    problem.  Hence, this is a regression.

(*) two commits from 2014-04-11, configured with and without dbgutil
    respectively, go into long loops, pegging the CPU; I cancelled
    first excution after half and hour, the second after about a
    minute.  This may be an entirely different problem, but I am
    leaving it alone for now.

(*) bibisect-42all latest: segfault before LibreOffice finished
    painting the dialog.  I am assuming that the reporter's crash is
    also a segfault.

(*) bibisect-42all oldest: no problem


Results from bibisect ...

from `git bisect bad`
---------------------
163838afd9b53b179a390d26e7a9efeed3098aef is the first bad commit
commit 163838afd9b53b179a390d26e7a9efeed3098aef
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Oct 17 22:47:20 2013 +0000

    source-hash-ea4fc480c7317b16f4abbafacda3872bb7413357
    
    commit ea4fc480c7317b16f4abbafacda3872bb7413357
    Author:     Eike Rathke <erack@redhat.com>
    AuthorDate: Fri Aug 9 22:59:31 2013 +0200
    Commit:     Eike Rathke <erack@redhat.com>
    CommitDate: Sat Aug 10 00:47:33 2013 +0200
    
        sal_Bool to bool
    
        Change-Id: If15bc8ae32674a7282861663ab4f91a958320a3c

:100644 100644 e45fdabf18736545b41132e1fda4f59911357d37 b7df7e39f81345dc8793d39192360a9d06553e87 M	autogen.log
:100644 100644 091ca23155a839fbaa2814f6e15a25c9e4b75c04 87a602ab68de3bf00b76ac4b4db6d877945620aa M	ccache.log
:100644 100644 6d8eeb764e9a963ffcde4ebcbddb6532e207a7c5 a9caa4f132520e09a54d47d02468f6b06cf91ab0 M	commitmsg
:100644 100644 3505f0453975480e0932e0890a4510706e6223b7 44c5d490a7e0e45f07d32a932f13d157af0033dc M	dev-install.log
:100644 100644 bad862e1b8f299ad71be272b9faa9bd17a304697 6bbe6d95fab814da068afff12f04ce7e01b2478f M	make.log
:040000 040000 179a0cf24fa6880227680470fd25f6145814ceed 16fc9912893b34fda6b494111599ee0ba84f45e0 M	opt

and from `git bisect log`
-------------------------
# bad: [793dbf6f80f497dfe587d560d6257f42a24273f6] source-hash-1581b1fc3ac82a7bd62df968226e98604a4ca52d
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [8092559c5013969ebda017d79200463b9b975038] source-hash-fd84daf696a368c2c7561b5253b32a63ecdeca4a
git bisect good 8092559c5013969ebda017d79200463b9b975038
# good: [8092559c5013969ebda017d79200463b9b975038] source-hash-fd84daf696a368c2c7561b5253b32a63ecdeca4a
git bisect good 8092559c5013969ebda017d79200463b9b975038
# good: [8092559c5013969ebda017d79200463b9b975038] source-hash-fd84daf696a368c2c7561b5253b32a63ecdeca4a
git bisect good 8092559c5013969ebda017d79200463b9b975038
# good: [0270ef1b76a6de423b30f7927362cc01c1a0fc38] source-hash-b1f7dd66b898b03cb4bd8d434b6370310ea95946
git bisect good 0270ef1b76a6de423b30f7927362cc01c1a0fc38
# skip: [ddb123cad22440994cd332d9985dd9558fd07e07] source-hash-647fb29f528b891a1c92846640f7865f5c1fbe7f
git bisect skip ddb123cad22440994cd332d9985dd9558fd07e07
# skip: [9d357dc6201f7cd91448595e0a3f89dfdae81946] source-hash-2304beaca33c63b94df99cb827716f00ce259f9a
git bisect skip 9d357dc6201f7cd91448595e0a3f89dfdae81946
# good: [ef72aa34cf4ee6399b192de28708d621c9680a50] source-hash-7e07a45500dcbb891a85f0bc9b7049cf4d50bba1
git bisect good ef72aa34cf4ee6399b192de28708d621c9680a50
# bad: [2472598a0b04eef3038d56137f27dc6dc1edf9e5] source-hash-5050dfc73f194d1d59222cac72e69a917655d816
git bisect bad 2472598a0b04eef3038d56137f27dc6dc1edf9e5
# bad: [f7c906a1908211e1da263a58e40cc8a3b227fcd9] source-hash-d3ff876f3c7f441fd72a037ed31fb973f223ca6d
git bisect bad f7c906a1908211e1da263a58e40cc8a3b227fcd9
# bad: [a2051f95d4e218b2cf99db275d9def985e40a082] source-hash-4450b1b93f7f7b5f97c631fe767b1156350a9227
git bisect bad a2051f95d4e218b2cf99db275d9def985e40a082
# bad: [1a9fd5fd81783fc13cf0b021e264215b81e9477a] source-hash-417d1c2b13cbd70300d2921b5667dfadc7e25895
git bisect bad 1a9fd5fd81783fc13cf0b021e264215b81e9477a
# good: [8adb68cd4f1764a2492a0d3ba21c760c3ed4a47f] source-hash-3cf0b5cdb05e1d77610431b1b1328102bf05b602
git bisect good 8adb68cd4f1764a2492a0d3ba21c760c3ed4a47f
# bad: [27588936d571262990ead936e6cc7274e38baaf5] source-hash-9499df9f8c73ac6370c389683ce2028e6432441e
git bisect bad 27588936d571262990ead936e6cc7274e38baaf5
# bad: [163838afd9b53b179a390d26e7a9efeed3098aef] source-hash-ea4fc480c7317b16f4abbafacda3872bb7413357
git bisect bad 163838afd9b53b179a390d26e7a9efeed3098aef
Comment 6 Terrence Enger 2014-04-24 15:12:53 UTC
I see no reference to an operating system other than Linux, so am
setting platform accordingly.
Comment 7 Terrence Enger 2014-04-24 15:20:14 UTC
Sorry, I just read comment 2 more closely.  Setting platform back to All.
Comment 8 Terrence Enger 2014-04-24 16:32:59 UTC
(In reply to comment #2)
>  2. Open a Writer/Web document. Write a Text, create a spreadsheet. Save
>     the document. It becomes very large.
>     You cannot open it with Libre again or only with strange changes.

This sounds like a different problem, maybe three problems: very large
file, cannot open, looks strange.  Can you file new bug reports for
them?  Please add me <lo_bugs@iseries-guru.com> to the cc.

Early questions will be:
(*) What means "very large"?  Please attach an example and tell us
    what part of the file should be omitted.
(*) Please attach an example which crashes LibreOffice when you try to
    open it.
(*) Please attach an example which looks strange when you open it.
    What is strange about it?  A screenshot can help.  What should it
    look like?
Comment 9 Andras Timar 2014-04-24 19:52:11 UTC
master does not crash. Patch for 4.2 is waiting for review on gerrit.

https://gerrit.libreoffice.org/9154
Comment 10 Commit Notification 2014-04-25 19:43:28 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d1d25c8cbc2962ce2501b4ed6034d2e4e4ccba9a&h=libreoffice-4-2

fdo#77242 fix crash


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Terrence Enger 2014-05-11 20:05:57 UTC
*** Bug 78528 has been marked as a duplicate of this bug. ***
Comment 12 Brian Piccioni 2014-05-12 20:20:12 UTC
I should add that, on a lark, I tried to replicate the bug on my office system. Writer does, indeed, crash when I attempt to create an HTML document and Format Page. This is an entirely different machine with Windows 7 

 

Brian

 

From: bugzilla-daemon@freedesktop.org [mailto:bugzilla-daemon@freedesktop.org] 
Sent: Sunday, May 11, 2014 4:06 PM
To: nairb1958@gmail.com
Subject: [Bug 77242] Writer/Web: segfault from Format>Page

 

 <mailto:lo_bugs@iseries-guru.com> Terrence Enger changed bug 77242 <https://bugs.freedesktop.org/show_bug.cgi?id=77242>  


What

Removed

Added


CC

  

nairb1958@gmail.com <mailto:nairb1958@gmail.com>  

Comment # 11 <https://bugs.freedesktop.org/show_bug.cgi?id=77242#c11>  on bug 77242 <https://bugs.freedesktop.org/show_bug.cgi?id=77242>  from  <mailto:lo_bugs@iseries-guru.com> Terrence Enger 

*** Bug 78528 <https://bugs.freedesktop.org/show_bug.cgi?id=78528>  has been marked as a duplicate of this bug. ***
  _____  


You are receiving this mail because: 

*	You are on the CC list for the bug.
Comment 13 Robinson Tryon (qubit) 2015-12-17 07:56:11 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]