Bug Hunting Session
Bug 77282 - "Edit Group" command should be "Enter Group" like in Draw
Summary: "Edit Group" command should be "Enter Group" like in Draw
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Laurent BP
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-10 19:55 UTC by Laurent BP
Modified: 2014-06-02 14:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2014-04-10 19:55:54 UTC
Problem description:
Two commands doing the same thing are not labeled in the same way in Writer/Calc than in Impress/Draw

Steps to reproduce:
1. Create a new drawing in Draw
2. Create two objects, select and group them (Ctrl+Shift+G)
3. Right click on the group
=> Command name is "Enter Group" if you want to enter (or edit) the group.
4. Copy group
5. Create a new Writer document (or Calc)
6. Paste group
7. Right click on the group

Current behavior:
=> Command is Group > Edit Group

Expected behavior:
Command should have the same name as it is doing the same thing

Help is confusing also as it speaks about "Edit Group" here:
https://help.libreoffice.org/Impress/Modify#Edit_Group

and Entering group here:
https://help.libreoffice.org/Draw/Grouping_Objects
Comment 2 Laurent BP 2014-04-11 06:46:51 UTC
Proposed commit
https://gerrit.libreoffice.org/#/c/8923/
Comment 3 Stefan Knorr (astron) 2014-04-11 09:10:54 UTC
"Enter" sounds better to me:
+ "Enter"/"exit" is the correct pair of opposites
+ "Enter Group" is also used in Inkscape
Comment 4 Laurent BP 2014-04-12 12:09:38 UTC
Commit to update help in the same way:
https://gerrit.libreoffice.org/8944
Comment 5 Commit Notification 2014-05-20 11:21:55 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bc34b4b2e2c7b9a891e2efae3b48a9a9c43b9d5a

fdo#77282 Replace "Edit Group" with "Enter Group"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 retired 2014-05-22 13:49:52 UTC
Confirming now LO writer now shows "Enter group" which seems to be the desired term.

So marking Resolved Fixed and then verified.

Please re-open if I'm mistaken and missed something.
Comment 7 Laurent BP 2014-05-22 15:16:05 UTC
(In reply to comment #6)
> Confirming now LO writer now shows "Enter group" which seems to be the
> desired term.
> 
> So marking Resolved Fixed and then verified.
> 
> Please re-open if I'm mistaken and missed something.

UI has been fixed, but help needs also to be updated. It should be soon be ready with commit 8944
https://gerrit.libreoffice.org/#/c/8944/

Please be patient :)
Comment 8 Commit Notification 2014-05-25 19:38:53 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=086fb237fd3350b4dba1bcfaf6165562578a8055

fdo#77282 Replace "Edit Group" with "Enter Group" in Writer as in Draw



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Laurent BP 2014-05-25 21:45:22 UTC
Commit for help integrated in master. Request to backport to 4.3
https://gerrit.libreoffice.org/#/c/9483/
Comment 10 Commit Notification 2014-05-26 09:53:09 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=9c2a8673716e0bf952413b528b3cdfc8d0d80585&h=libreoffice-4-3

fdo#77282 Replace "Edit Group" with "Enter Group" in Writer as in Draw


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.