Download it now!
Bug 77300 - Updating range names messes up formula.
Summary: Updating range names messes up formula.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.3.0 target:4.2.4
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-11 04:20 UTC by Kohei Yoshida
Modified: 2014-04-14 16:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kohei Yoshida 2014-04-11 04:20:19 UTC
1. Open https://bugs.freedesktop.org/attachment.cgi?id=97154
2. Ctrl-F3 to Open the "Manage Names" dialog.
3. Change the end cell position of the range of "AcBalances" from $H$37 to $H$38.
4. Click OK to dismiss the dialog.
5. Ctrl-Shift-F9 to re-calculate.

At this point, cells beginning with D3 and onward all become Err:520.
Comment 1 Kohei Yoshida 2014-04-11 04:21:25 UTC
This is a follow-up Bug from Bug 75741.
Comment 2 Kohei Yoshida 2014-04-11 04:24:30 UTC
I'll take a look.
Comment 3 Commit Notification 2014-04-11 04:45:22 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bdc8d5f9e712fce35098352b8c1d9028f4095d8c

fdo#77300: Add test for this.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2014-04-11 04:45:34 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=66c6a3bfc9cd89c562107d3d369b3d82bae94d68

fdo#77300: Don't re-compile formulas when the hybrid formula is not there.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Kohei Yoshida 2014-04-11 04:45:55 UTC
4.2 backport: https://gerrit.libreoffice.org/8928
Comment 6 Kohei Yoshida 2014-04-11 04:46:24 UTC
Yeah it was a very simple oversight.
Comment 7 Commit Notification 2014-04-11 04:56:18 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ed9d606306cc66ec89e9a6696494b6cdefd9b208

fdo#77300: Add more test to cover the shared formula case.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-04-11 04:56:30 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0e63ca4fde4e446f346e35849c756a30ca294aab

fdo#77300: Do the same for the shared formula case as well.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 tim 2014-04-11 08:12:44 UTC
Thanks for the very quick response.  I'll test tonight & tommorrow (I'm not sure if it'll be in the daily build on 11/4).
Comment 10 Commit Notification 2014-04-11 11:10:19 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bb14c069cc58a9a4359299b4ad865f49eb495799&h=libreoffice-4-2

fdo#77300: Don't re-compile formulas when the hybrid formula is not there.


It will be available in LibreOffice 4.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Kohei Yoshida 2014-04-11 12:23:15 UTC
I'll mark this fixed.  You may want to give it an extra day just in case.
Comment 12 tim 2014-04-12 10:04:00 UTC
I have now tested this with 

http://dev-builds.libreoffice.org/daily/libreoffice-4-2/Win-x86@42/2014-04-12_03.20.43/libo-42~2014-04-12_03.20.43_LibreOfficeDev_4.2.4.0.0_Win_x86.msi

I have verified that with the test document, and with the original large set of sheets from which the test was produced, the problem is now fixed.  I have therefore set the status to verified.  Thanks for the quick fix.


I will also verify the original problem has been fixed (#75741)

I have been unable to do a full test of my 'live' spreadsheet, drawing data from my database, because I cannot get the daily build to install on ubuntu.  There seems to be some error in the version of ure expected, as below:

 dependency problems prevent configuration of lodevbasis4.2-core01:
 lodevbasis4.2-core01 depends on libreofficedev4.2-ure (<= 4.2.4.0.0); however:
  Version of libreofficedev4.2-ure on system is 4.2.4.0.0-1.

Nonetheless I have no reason to suppose that there will be any further problems in this area.  I'll test again when 4.2.4 reaches pre-release in the ubuntu ppa.
Comment 13 tim 2014-04-14 15:16:26 UTC
I have now managed to install a parallel version of 4.2.4.0 (dated 14/04/14) on ubuntu, by finding a different set of installation instructions (at https://wiki.documentfoundation.org/Installing_in_parallel).

To be brief, my full spreadsheet now works OK.  Thanks.

I would, however, note that changes to the range name now take minutes on a fairly fast machine (8 * 2.5 GHz CPUs).  I thought it had crashed/locked-up, but it did complete eventually.  

I strongly suggest an item in the release notes indicating that some may find such changes very much slower than before in complex sheets.
Comment 14 Kohei Yoshida 2014-04-14 15:38:41 UTC
(In reply to comment #13)

> I would, however, note that changes to the range name now take minutes on a
> fairly fast machine (8 * 2.5 GHz CPUs).  I thought it had crashed/locked-up,
> but it did complete eventually.  

It would be nice to have a bug filed for this.
Comment 15 tim 2014-04-14 15:58:11 UTC
#77439 at your service :)

I'm not exactly clear when to raise new reports and when not, as will be apparent from my previous comments, so please bear with me.
Comment 16 Kohei Yoshida 2014-04-14 16:03:23 UTC
Thanks a lot!

BTW, bugzilla automatically detects and links a text fragment in the form of "Bug xxxxx". So when filing a bug that's referenced to an existing one, you can use this syntax to have it auto-linked.

Demo: Bug 77439