Bug Hunting Session
Bug 77325 - Selective reset of style attributes
Summary: Selective reset of style attributes
Status: RESOLVED DUPLICATE of bug 47807
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-11 12:27 UTC by Ulrich Windl
Modified: 2018-10-30 21:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Windl 2014-04-11 12:27:52 UTC
Why defining a style based on (linked to) another style, you cannot easily revert one modified attribute to the inherited (copied) one (once you pressed OK). If you changed an attribute by mistake, you can only reset the complete style (which is not very efficient and satisfying).
Therefore I suggest a dialog that pops up when you "reset" a style that lists all modifies attributes (relative to the linked style) with a checkbox. If checked that attribute is reset to the inherited value; if unchecked, it remains.
That seems to be an easy to understand solution for the problem.
Comment 1 Ulrich Windl 2014-04-11 12:29:00 UTC
s/Why defining/When defining/ #I wasn't fully awake
Comment 2 Joel Madero 2015-02-25 21:55:32 UTC
This is a duplicate - marking as such. not 100% the same but close enough that there is no reason to have two bugs open. Please comment on the other bug with any additional findings. Thanks!

*** This bug has been marked as a duplicate of bug 88921 ***
Comment 3 Thomas Lendo 2018-10-30 21:19:36 UTC

*** This bug has been marked as a duplicate of bug 47807 ***