Download it now!
Bug 88921 - Allow undoing changes to styles
Summary: Allow undoing changes to styles
Status: RESOLVED DUPLICATE of bug 47807
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Styles Undo-Redo
  Show dependency treegraph
 
Reported: 2015-01-30 04:41 UTC by evaned
Modified: 2018-10-30 21:19 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description evaned 2015-01-30 04:41:13 UTC
1. Create a new presentation
2. Draw a shape (rectangle, circle, etc.)
3. Right click -> "Edit Style"
4. Change something; I checked this with changing the area fill and line style
5. Click OK
6. Press ctrl-Z or Undo from the Edit menu

Expected: the change is undone
Actual: it undos the previous change, i.e. the drawing of the shape if you followed my instructions

(This made #88920 rather more annoying)

This is inherited from OpenOffice; checked with OO 4.1.1.
Comment 1 Joel Madero 2015-01-30 05:32:48 UTC
So you want the undo to revert your changes to the style? That is dramatically different from how undo currently behaves so I think this would be an enhancement request.
Comment 2 evaned 2015-01-30 06:04:53 UTC
You can call it an enhancement request if you want, and I don't know how things are implemented.

But from a user's perspective, I don't view it as different from undoing any other change. I made a change to the document; "undo" doesn't undo that change. I'm not asking for "undo" to revert some extra-document action like a change to program options or something like that (see Adobe Lightroom for a program where undo takes actions like that).
Comment 3 Joel Madero 2015-01-30 06:16:44 UTC
I'll get a second opinion about this one and come back to it. I'd say that it's either between a minor bug (slows down professional quality work but won't prevent it) or an enhancement request.

I'll ping the QA list to get additional input. Thanks for your understanding.
Comment 4 Joel Madero 2015-01-30 06:27:43 UTC
Talked to a colleague on the QA team and he agreed that it's an enhancement. Marking as such
Comment 5 Cor Nouws 2015-02-03 10:46:49 UTC
In Writer, after editing styles, you _can_ undo. But that does not always work..

A bit _buggy_ imo ;)
Comment 6 Joel Madero 2015-02-25 21:55:32 UTC
*** Bug 77325 has been marked as a duplicate of this bug. ***
Comment 7 Andreas B. 2016-11-18 20:20:16 UTC
In my Opinion this is a Bug, because it's working sometimes.

I list here, what is working and what not. If there would be nothing working, I would say it's an enhancement, but with this list, I would say its a Bug.
(I didn't test every setting, this is only an Overview)
I changed the importance to "normal"

Working:
 Calc:
  Change name of a Style
  Changing Parent
  Change Font
  Change Font Effects
  Aligment
  Border
  Background
  Cell Protection
 Draw:
  Nothing found, not all Tested
 Writer:
  Change highlighter Color
  Indents and Spacing
  Alignment
  Text Flow
  Font
  Font effects
  Position
  Outline and Numbering
  Gradient
  Transparency
  Border

Not Working:
 Calc:
  Tab "Numbers" changing
 Draw:
  Background
  Line
  Change name of a Style
  Change Parent of a Style
  Font
  Transparency
 Writer:
  Change name of a Style
Comment 8 Kenneth Hanson 2017-12-18 02:50:08 UTC
Still an issue in 5.4.3.2. I also recall undo working for changes to styles *sometimes* but not always, though I haven't tested it systematically.
Comment 9 Thomas Lendo 2018-10-30 21:18:07 UTC

*** This bug has been marked as a duplicate of bug 47807 ***