Download it now!
Bug 77331 - Text boxes inside charts disappear!
Summary: Text boxes inside charts disappear!
Status: RESOLVED DUPLICATE of bug 74333
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-04-11 15:29 UTC by blargh
Modified: 2014-04-13 23:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description blargh 2014-04-11 15:29:52 UTC
If there is a text box inside a chart (either in Calc, or if the chart was pasted into Draw). After saving the file, closing it, and opening it again, all the text boxes are gone.
The text boxes also disappear if the chart is simply copy-pasted.

I used LibreOffice 4.1.5 until today and this didn't happen. I'll go back to it, as this bug is a a complete no-go for LibreOffice 4.2.x...

Thanks and
all the best!
Comment 1 blargh 2014-04-11 15:45:28 UTC
I just tested on version 4.2.2 and the same happens.
All the text boxes inside charts disappear.
Comment 2 m.a.riosv 2014-04-12 11:43:08 UTC
Hi Blargh, thanks for reporting.

I can reproduce the issue with:
Win7x64Ultimate
Version: 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Version: 4.2.3.3 Build ID: 6c3586f855673fa6a1576797f575b31ac6fa0ba3
Version: 4.3.0.0.alpha0+ Build ID: f9cc0daec26016722bf5260e4e2634e6dcfe25a2
   TinderBox: Win-x86@39, Branch:master, Time: 2014-04-12_01:41:16

Last version working:
Version: 4.1.6.0.0+ Build ID: 0b772a163b2536fc55aa3b4de925119e33af769

Creating the text box with 4.2 or 4.3 and saving, saves the text box because if you open the file with 4.1.6 it is there.

Seems the issue is opening with 4.2/4.3.

Regression from 4.1.6
Comment 3 Markus Mohrhard 2014-04-13 23:12:43 UTC

*** This bug has been marked as a duplicate of bug 74333 ***