Download it now!
Bug 77339 - Regression in 4.2.3 over 4.1.4: EPS graphics inserted in Writer are gone in PDF export
Summary: Regression in 4.2.3 over 4.1.4: EPS graphics inserted in Writer are gone in P...
Status: RESOLVED DUPLICATE of bug 64161
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha1
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-04-11 18:56 UTC by Gerry
Modified: 2015-12-15 11:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Graphics gone when PDF export.odt (14.86 KB, application/vnd.oasis.opendocument.text)
2014-04-11 18:56 UTC, Gerry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2014-04-11 18:56:29 UTC
Created attachment 97233 [details]
Graphics gone when PDF export.odt

Since I updated to 4.2.3 today, I encounter a severe problem when exporting documents with embedded EPS graphics to PDF. The graphics are simply gone in the PDF export. 

This is a regression from 4.1.4, where the PDF export just worked perfectly with EPS graphics!

How to reproduce:
* Open attached odt-file
* Export a PDF
-> Where the EPS graphic is supposed to be in the PDF, there is simply empty space.

Version: 4.2.3.3, Build ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff0 (downloaded from LO website) (Ubuntu 13.04)
Previous version (where the PDF export worked perfectly): 4.1.4 (from Ubuntu PPA).
Comment 1 Cor Nouws 2014-04-11 23:03:52 UTC
Hi Gerry

thanks for the report. Ok in 4.1.5.3
Not OK in 4.2.0-alpha1
 > regression
Comment 2 Gerry 2014-04-12 07:54:25 UTC
I feel free to increase the importance of the bug to "high", because:
* the most recent version of LO 4.2.3 is affected
* bug seems to affect all OS 
* data are lost in PDF export
* it is a regression from 4.1.x to 4.2.x
Comment 3 Andras Timar 2014-04-14 21:22:05 UTC
2e5167528f7566dd9b000e50fc1610b7bf99132a is the first bad commit
commit 2e5167528f7566dd9b000e50fc1610b7bf99132a
Author: Armin Le Grand <alg@apache.org>
Date:   Thu Oct 31 14:43:21 2013 +0000

    Resolves: #i123500# unified Graphic processing to use GraphicPrimitive2D
Comment 4 Gerry 2014-04-24 07:20:45 UTC
The same regression seems to exist in AOO after Armin's commit in October: See https://issues.apache.org/ooo/show_bug.cgi?id=124684
Comment 5 Gerry 2014-04-24 07:33:17 UTC
Another related bug seems to be fixed in AOO on the 23rd of April with two commits, see: https://issues.apache.org/ooo/show_bug.cgi?id=124686
Comment 6 Jean-Baptiste Faure 2014-04-28 10:32:19 UTC
Perhaps same root cause for this bug and bug 75216

Best regards. JBF
Comment 7 Jean-Baptiste Faure 2014-04-29 11:27:31 UTC
Fixed since the fix for bug 64161.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 64161 ***
Comment 8 Robinson Tryon (qubit) 2015-12-15 11:03:22 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]